Issue with the Witch Queen battle

Game mode: [Online | pve
Problem: [Crash | Bug | Performance | Misc]
Region: [Here]

Issue with the Witch Queen, if I attempt the mission alone its no issue. If I attempt with others Her monologue does not load. The statues disappear after being defeated. And witch queen does not leave throne. The barrier wall doesn’t fall.

Steps on how to reproduce issue:

Had a similar issue. Basically what I had to do was to get the other party to log out and I also logged out by the door. When then waiting about 5 mins, logged back in and the room had reset and we were able to continue the quest.

That works. Best I can muster is this glitch occurs if you attack the 2nd statue before she activates it. But I may not know about other ways to trigger this glitch.

I ran it solo a couple days ago. Dialogue never appeared for me, but the encounter script ran its course anyway. First time I attempted it it bugged because I over zealously went straight for the 2nd statue, ran it again later with my wife, same problem. Ran it again after soloing, waited… Ran it fine. Still no dialogue any time.