Its baaaack... Arrow in Hand

Game mode: [Online official]
Type of issue: [Bug]
Server type: [PvE]
Region: [America]

[Arrow shows in hand, on melee weapons and tools]

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Have a bow equipped and use it. (I had Flawless Pictish Bow with Advanced Weapon Enhancement and Iron Arrows equipped)
  2. Switch to a melee weapon or tool while still in combat (Have to pay closer attention to see exactly when this happens).
  3. Arrow shows in hand, weapon or tool.
  4. Easily resolved by removing bracelet.
1 Like

It was never gone, though less usual than months ago, it still was never completely solved. At some point this bug became rare to happen but still was was there. Personally I’ve gotten used to it, relog and gone.

I hadn’t seen it in almost a year so thought it’d be worth writing up.

That was my impression too, that at some point they fixed it, but it’s been there all the time, just not happening so often. I guess I just got used to it since it’s not mechanic-breaking kind of bug. Indeed it’s worth reminding devs that it is still there and see if once worse bugs get fixed, less important ones get also fixed and we get the “finished” game we all would like to see!. :grinning:

Yes, unfortunately, or never gone completely.
Hard to tell what is the case here, but i agree while not a big deal, and in any way game-breaking, it’s tiresome to see it back again and again.

Lately i had a thrall with that bug, did see it still on own char. But no, there my new T4 was standing, with a pretty arrow in her hand. And thralls no relog, no remove bracelet to correct it. Live with it or kill your thrall. :wink:

While i agree it’s an old bug, and not gamebreaking, i think it’s still good to remind these bugs, and not simply get used to it.
The arrow bug i know it since i play this game, and this is EA.
But honestly, it would be so nice to see it gone for good. :grinning:

Yers, this has happened to me too, but only once in the last many months. It was resolved the same way as the “vertical aiming bug”, ie. anything that reloads your character model. I used the CharEditLite mod, and the arrow was left hovering where I reloaded my character, and disappeared some time later (not sure when exactly). I too was under the impression that it had been fixed.

1 Like

Hey there,

We’re aware of this issue and our team is looking into it.
Thanks for your feedback


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.