Javelin (throwing)


My friend and I just started playing a few weeks ago and I noticed that when using javelins (1 handed) they flat out just disappear when using them. I understand 1 is “consumed” upon throwing them. That is not what I’m talking about. I mean, if I use a Javelin + Shield, and I simply equip and unequip the javelin or javelin+shield, it just disappears completely. Even if I never use it once. I’m assuming this is a bug. If so, could there possibly be any plans to fix this in the future? I’ve searched for this issue, and found others discuss it on other forums but never saw any kind of fixes for it, or any kind of answer about it other than it happens when you throw them. Again, this happens even if you never use the javelin at all and simply equip it and unequip it. It literally just disappears from your hotbar and is gone for good.

1 Like

Sounds like you are using mods. This is not a base game issue.

1 Like

No we aren’t running any kind of mods at all. We have no desire to use mods. We’re playing the base game.

Yes, when you have thrown your last javelin and the count is actually zero, you retain a ghosted copy. It renders like normal and even does damage but cannot be thrown. Once you change weapons via hotbar selection, that ghosted copy disappears. I’ve reported this as well but I think FC see this as a feature. I guess because it doesn’t leave you completely empty handed when you run out of javelins or something.

See I’ve heard other people say this, but this is not my issue. Hear me out…

Let’s say I made 5 javelins and stacked them, and I NEVER once thrown any of the spears…

they’re literally disappearing after sheathing. Not immediately. It seems to happen over time. But only use is with a shield so none of them were thrown.

ok I just tried to recreat the problem and I did… it appears that sometimes when I right click (I’m using a shield… so it should not throw the spear) it basically acts as if I am throwing the spear so… it’s using a spear even though it’s not being thrown. Then it does the ghosting where when I sheathe… the javelin disappears (because it acts as if its been thrown).

edit: Also, what’s weird is when these javelin are “thrown” while using a shield, they simply disappear. They do not actually get thrown and they’re unable to be picked up. They’re just gone from the game.

Not how it works. You still throw the javelin with a shield in the vanilla game.

Edit: I see what you mean now, it still throws it though. There’s a bit of wonkiness though. Easiest fix for the user, don’t use just 1 javelin. And secondly, realize that its going to throw no matter what if you click right click.

I would type up a proper bug report, but as we are about to switch to 3.0 any day or week now, it would be pointless to do so. When things settle down with 3.0 and the smoke starts to clear, I’ll revisit it.


Interesting. I don’t think I’ve ever used javelin with a shield before. Now I wanna try it though. :slight_smile:


ah ok ty… well on my screen when I right click WITH a shield, the javelin does a stab… I wish they’d do something about this. I love using the jav+shield. I guess I’m just gonna have to try and not right click at all. But yeah I’ll use a few in a stack just in case. What I dont get is why the javelin is disappearing from the environment when I throw it… we’re talking 1 throw. It’s not like it’s breaking.


There is a percentage (I don’t remember what it is off hand, 10-25%, something like that) where the javelin breaks upon throw.


If so that means you’re out of javelins. RMB will always throw until the count is zero… then it stabs. If the count is zero then sheathing will make the “ghosted” copy disappear as you describe.

Notice the count in the hotbar - it tells you how many you have left - with no number at all when the count is zero.

1 Like

ok that makes sense. TY!


Thank you for the explanation, I appreciate it. I really hope they do something about this but at least I know I can play with javelins I just have to be careful.

1 Like

Last I recall Javelins had this pain in the ass bug, when stacking a damaged one on an undamaged one, itd damage all of them. This could end up flat out destroying them.

I learn this the hard way… It’s called riptide :rofl::rofl::rofl:. Omg I remember I was crying for days. The night that this happened I couldn’t sleep from the frustration :person_facepalming:t3:.
@Fenris84 welcome to the forum m8, it’s really good you mention this “issue”, I hope this conversation to be helpful to a lot fellow exiles. I love your Spartan way :wink:, keep it going :+1:t6:


I recorded my experience with Javelins in TestLive 3.0

They fixed the ghosting thing… Nice! They still need to work a little on hot-bar stack handling as you may notice. And I sure want a bigger stack-size… Ten just isn’t enough… 50 or 100 would be cool! I didn’t check numerically but I think they lightened the load a bit too because usually that many stacks would encumber me - though might be due to other settings - like I said I didn’t check. :stuck_out_tongue:

The video plays at 1.8x speed at 60fps naturally so if you wanna see normal speed for some reason just set YouTube to play at 0.75 and it’ll be close.


Javelin and Shield was this one’s go to before Shortswords were a thing. You can throw it, you can stab and sweep with it, you still have a shield for defense. The stats were… okish, but for an all in one very light weight weapon it was adequate.

The blunted javelin used to be one of the better subdual tools, and sorta looks like a swagger stick, so one could envision caning an insubordinate wretch into compliance.
Also, for awhile, there was a stutter one could do with the Javelin and Shield that allowed rapid stabs while turtling. It was a stamina hog and got patched out with other animation cancels, but for awhile it was a reliable linear stun lock with little vulnerability.

Very sad that the Khitan (or other cultural) Javelin never got implemented, but they may resurface in the shop later. How did they say it on the show? I’d buy that for a dollar!


Hehe, nice Robocop reference. :slight_smile:

I never tried a shield because the controls are whack (for me). I need certain actions to be on the mouse cuz of sports injuries. MB1: Sprint, MB2: Crouch, MMB: Roll-dodge, and then heavy and light on RMB and LMB. I can’t accurately or timefully use Ctrl, Alt, or other keys (besides spacebar) at the same time as the WASD keys. So the shield is out for me unless I can just hold it down forever. Since the shield drops when hit that’s out too. So no shield for me unless the timing is really slow (like with a truncheon).

And that’s fine because almost all enemies have very predictable attack patterns that can easily be sidestepped or roll-dodged away from. I think that makes it a little more fun too: instead of just standing there holding up your shield you have to dance! :women_wrestling: :woman_cartwheeling:t6: :person_fencing:

1 Like

I honestly hope not. As far as I can tell, the Javelins art and models are already in the game, just not attached to any usable item. They should release them as a retroactive patch into the DLC packs they belong to.

1 Like

While this one agrees in principle…
On a practical level, devs above have already noted nothing will be retroactively added to DLCs and that further development of DLC material would require financial incentive or something alongst those lines. Further, they noted that future offerings for sale that include existing DLCs will be discounted for owners of that DLC, which almost screams a “Completed” Khitan or Pict set, which has the current DLC bits + the unimplemented parts.

So this one expects it’s BLB (Black Lotus Bizarre) or nothing. Unfortunate, but not the end of the world.