Main quest broken


#1

Game mode: Singleplayer
Problem: Bug
Region: [EU]


So I got the Staff of the Triumvirate, awakened it at the Tower of Bats, then it told me to find the Archivist, which I did. Then it speaks about the priest-king who went to the North to battle his son or something and I decided to go there and look for the first relic. I found the Barow King, killed the guy inside, but there was no relic after harvesting the body.

I tried that three times, nothing.

Then I thought about speaking to the staff again, and realized it wasn’t in the chest where I left it. Instead I just have a blank square with a number for description.

I went back to the Dregs, killed the serpent again, and there was no staff. So now I’m stuck, I don’t have any staff, the relics won’t drop from the bosses. I only have the three Scourgestone pieces, those drop normally but not the other relics.

I’ve also read that there should be an altar in Chaosmouth to assemble the pieces, but there is nothing there.

I think my staff disappeared after the latest patch.


Steps on how to reproduce issue:

  1. Install the game
  2. Play the game
  3. It’s bugged AF
  4. pls fix

#2

Switching builds ‘may’ fix your problem. It could be worth a shot.

I had no altar in SP so I switched from TestLive to Live and checked someone’s dedicated server. Still no altar. I switched back to TestLive and the altar was there. Steam redownloading files may have fixed my problem. Someone else in the following thread said it fixed theirs as well.

Hopefully it fixes the altars as well as the drops.


#3

How do you do that in singleplayer ?


#4

Right click on the game in Steam, click properties, click betas, select TestLive.
The game will download an update which was around 830MB last time I checked.

There’s no guarantee this will help but it fixed the altar problem for me and at least a couple others.


#5