[PC] Altar of Chaosmouth

Game mode: Official Live
Problem: Bug

My boyfriend and I went to pay the altar a visit on an Official Live server. He can see the altar, I can’t. There’s nothing there at all to interact with.

1 Like

Ever figure this out?

Nope. While I was up there I spammed ‘e’ where I could see it on my boyfriend’s monitor and go no results. Haven’t heard anything

Ah, that sucks. I appreciate the response.
I just gathered all the items last night and have no altar to use either.

I just went back to this location and the altar is now there.

I have done nothing that should have triggered it to appear. I haven’t killed any bosses, talked to any NPCs, nothing. Strangely, it has 6 crystals in it though I’ve never touched (or seen) it before and I’m on Singleplayer.

What I ‘have’ done is switch from TestLive to Live and then back to TestLive. So perhaps Steam redownloading some files corrected this issue.

If you give that a shot, let me know if it works.

Altar of Chaosmouth

1 Like

I’ll give it a shot

Up : I have the same issue here :frowning: and though I came back and reloaded thousands times, no change at all, still no chaosmouth altar x’( T_T

Anyone got any clue ? Funcom are you aware of this and got a fix in the pipe somehow ?

I have gathered all the requirements but is there anything to do to “activate” the apparition of the altar ?

You could try what I mentioned above. Otherwise I have no idea.

Have no clue how you switch from Testlive to Live :’( and then back

Actually yeah, how do I switch to testlive and back?

In Steam, right click on the game, click Properties, click Betas and then select TestLive.
Switching from one to the other will download about 800MB.

There are 2 ways to go around bugs in this game. Sadly, not all bugs can be “fixed” this way.

  1. Restarting game / Relogging
  2. Removing the bracelet and respawning (don’t forget to pace a bedroll nearby)

Thanks for the clue, i m gonna try this right away
:slight_smile:

Restarting the game definitely didn’t work for me. I even went to another player’s dedicated server to check and I couldn’t see the altar there either.

I didn’t try suicide, but Steam re-downloading files seems to have fixed it for me. (Switching from TestLive and back)

Neither of the easy fixes worked for me? Anyone made this work?

I tried switching to Testlive and back with no dice. :frowning:

1 Like

Bah. That really sucks.
I didn’t do anything else that could have fixed it… So I have no idea on what else you could try.

Actually it doesn’t suck ‘that’ bad. Completing the story is completely and utterly pointless. Worst ending for a game I’ve ever seen in 30 years of gaming. It’s not worth your time.

Atari games had better endings.

GEE !! IT WORKED FOR ME !!! Though I didn’t do the double switch but a single one : was playing Live, I switched to TestLive and ran back the game. Altar was here :slight_smile:

Thanks a super lot ExNihiloish

1 Like

That’s great news @cocolapin. I’m glad it helped someone.

cannot join my server while on testlive build , but it did show the altar in singleplayer, guess we need to wait for a live update