Microsoft store version bugs

Game mode: Single-player
Type of issue: Crash | Bug | Performance
Server type: offline
Region: offline
Mods?: Yes and No.
Edition: Microsoft Store

Bug Description:

Issue #1 when ever I lock on to a target my fps drops from 60+ fps to 3 fps no matter where I am what the target is the second I hit the button to target an enemy the FPS immediately drops to 3 FPS I can’t move and can’t unlock the target again and obviously die. I am using a controller and have tried to remap the button but still happens, if I engage enemies without locking on everything is fine but it of course makes combat much harder.

Issue #2 when ever I disconnect my headset while in game the game completely freezes requiring me to go to task manager to end task and restart the game.

This happens with mods enable or not.

Installed Mods:

Pippi, fasionist, age of calamitous and better thralls.

Steps to Reproduce:

Lock on to target for issue 1
disconnect headset for issue 2


Thank you for your report. Could you share more information with us?
Regarding issue #1:

  • Would you be able to record a video of the matter happening?

Regarding issue #2:

  • What are the model and specs of your headset?
  • Are they USB?
  • Which version of Windows are you running?
  • Have you updated your audio drives recently?

Thanks in advance.


Regarding the headset they are Turtle beach Stealth 700 I believe connected through Usb dongle. But it is the other matter that is most annoying without being able to lock on combat is very hit and miss, I will try to record something maybe through the nvidia overlay. It is just strange that it drops to exactly 3fps every time.


Also it is windows 10 home and yes my drivers are up to date.


Thank you for the additional information, we’ll register the issue with the headset while we wait for your video. :slight_smile:

1 Like

Well I don’t know what to say but I went to record a video of this occurring and I had previously disabled target lock so I didn’t hit it accidentally, so today I re-enabled it and for the life of me it is working perfectly. I even tried different weapons, enemies and anything else I could think of and it never happened, if I figure out what was causing it I will get back to you.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.