Modified armor unrepairable


#1

I attached some pieces to make armor lighter and then tried to repair the armor. The little repair cog appeared on the icon for each armor piece and never repaired/went away. The armor is no longer usable because it is currently being repaired, but nothing is happening.


#2

That is kinda an annoying bug.


#3

I did the same thing with my Kambujan Shaman armor. I left the armor in a chest and waited until after the morning (5:00 am EST) official server restart the bug disappeared.

I have not tried repairing the armor again since then, but I imagine it will do it again. I make it a point to repair the modified armor just as I am logging out for the night. That way the armor will be usable the following morning.


#4

Yeah, actually it is happening to me with the same armor. My wife wears it so of course I don’t pay much attention to the name of it but that’s the one! (haha)

I saw that the cog disappeared yesterday so I went and tried to repair it to see if it was fixed - not yet.

Also, yours actually repair? Mine sit at the same durability. Interesting


#5