Mouse pointer wrong position in fullscreen when taskbar is at the top


#1

Game mode: Official Testlive
Problem: Bug

Hi there,

The game is really amazing and you made a huge progress since the EA.

Under Windows, I noticed a bug that’s really problematic and especially related to Unreal Engine (other games like Everspace have the same issue). It’s related to Win32 API to get screen coordinates or the way coordinates are computed.

When we put the task bar at the top under Windows and we play in fullscreen (not windowed fullscreen), the coordinates of the mouse cursor have an offset corresponding to the height of the task bar. It’s really annoying because we can’t select directly the item we want to click on and we have to click lower. It’s especially annoying in all menus.

Perhaps this bug has been fixed in recent Unreal Engine versions, but I have no idea how to verify that.

I’m also an open-source developer working on MMORPG so I could get Unreal Engine source from Github and try to find and fix the bug, but I suppose your or Unreal Engine developers are more expert than me to find it :slight_smile:

Thanks a lot :slight_smile:


Repro steps:

  1. Under Windows, put the task bar at the top and lock it eventually
  2. Start Conan Exiles
  3. Put Conan Exiles in true fullscreen (not windowed)
  4. Move the mouse pointer in menus, you’ll see that the highlighted items are not under the mouse pointer

#2

It looks like the bug is located in :
Engine/Source/Runtime/ApplicationCore/Private/Windows/WindowsWindow.cpp


#3

Hi. I have the same issue and it´s really annoying. I cannot even craft some items because I cannot click on them at all with my mouse pointer completely out of the screen.
So the temporary solution might be not to play the game fullscreen I guess?
I hope the bug will be adressed soon, because it´s really nice game and these things diminish the overall impression of it.


#4

Me too, I noticed it in several games using Unreal Engine. In 2017, this bug wasn’t present.


#5

I had the same issue as well, but I “solved” it by simply using the Windowed Fullscreen setting. So, if you can, do that.

My mouse now, thankfully, lines up.


#6

Yep, I suspect we don’t have the choice :frowning:

But I think, in real fullscreen, the game is smoother.


#7