Mummy of the Ring does not spawn!

Game mode: Online official
Type of issue: Bug
Server type: PvE
Region: Europe
Mods?: No

Despite completing all preceding journey steps, placing all required items in the altar, crafting the keystone, then progressing to the Citadel of the Triumvirate - no Mummy has spawned. Only a giant snake. Have also killed the snake several times, but no journey step and no Mummy.

Installed Mods:


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Complete every journey step up to Chapter X, Step IX.
  2. Collect all mats required to craft the keystone.
  3. Place mats in altar to craft the keystone.
  4. Take keystone to Citadel of the Triumvirate.
  5. Be disappointed and fight a big snake. Get bonus gold.

They never finished main story thus there is no mummy of the ring in game since released in welll day 1 of early access


you can spawn it via admin command. But this bug was reported in 2019 and still no fix

1 Like

Well I meant on official but the mummy was never fully put in to the story physically thus the mummy hasn’t appeared even in early access if I understand correctly thus it’s not a bug just unfinished content


Then WHY its still unfinished? you cant complete journey without it. FC better or add it do the game or remove that journey step that requies you to run single player mode with admin panel and spawn that mob!
they working on Siptah since when, 2020? Since then there were literally zero updates to Exiled lands map, that means they think its finished? Or not?
Its very nice to pay money for game that you cant finish without use of unattended functions.

i hope @AndyB or @Ignasi or @Dana will look into this issue

Mummy appears in the purge.

Hi @Fenharell

We’ve passed this information over to the rest of the team for further investigation.

Please keep an eye out on our future updates as we are always working on improving Conan Exiles.


Strange, never saw it there, was 10+ purges already still no mummy. I spawned it via admin panel and it fully works, why not put it in some place in game then? Without random spawn.

The purge is called A tide of Undead.
When I first saw it, I kept thinking what a terrible dog-headed man with a Stygian sword was. And then I found on the wiki that this is the Mummy))

This is very stupi that yoi can only find it there

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.