Mummy of the Ring still not implemented.. but there are new map

Seems weird. I thought someday devs gonna implement the rest of the story - with mummy end the ring - but instead of it, they create new map(( bad funcom(

6 Likes

They added a new story just not the one you want to have :smiley:

2 Likes

:expressionless: Yes - the adding a new story without ending existing one

7 Likes

I very firmly agree. There has been a lot, and I mean a LOT of people asking about this for quite some time now. I have always asserted that the Journey Steps are the closest thing we have to a main questline in this game, and it is still incomplete. I feel that after 2.5 years we have been very patient on this issue. I would really like to see the the Mummy of the Ring implemented into the game sooner rather than later.

10 Likes

Yep, Its one of those things, were you see on PC side that some of quest is sorta there… and you wounder why it was never added. Or simply shortcuted to appear at forge site, or back of room behind other guy.

=/

1 Like

I agree, we definitely need to get a completed story with the Mummy of the Ring. I think The devs hinted about it once in a livestream a while, but I can’t remember which one. I hope it has not been forgotten.

Incidentally, did you know that there is a hidden dialogue from the Awakened staff that he only says after you kill the Mummy of the Ring. It’s pretty interesting, clearly it was meant for implementation but was never completed. I found it once in Single Player while experimenting with the Staffs dialogue order.

2 Likes

Storylines and features are constantly pitched, tried and in some cases scrapped. The Mummy portion was scrapped. This has been stated in teh past. The story is complete.

Will Funcom someday decide upon some other use for the Mummy? Perhaps. But not today. If they didn’t provide the Devkit, people would have no idea.

1 Like

This post was flagged by the community and is temporarily hidden.

1 Like

Im sorry but you have made a number of claims here which are either ill informed, or blatantly false.

Curious, I dont seem to recall Funcom ever saying that. Could you please link me to where they made this statement? Even if that were true, which it simply is not, then the Chapter 10, Step 9 Journey Step would still need to be replaced with a suitable alternative.

Again, this is blatantly false. I am a ps4 player, and as such, do not have a DevKit. Nor do we need one to know he is in the game (or at least should be…). How?

  1. The Journey Step for ‘Ch10, Step 9: Defeat the Mummy of the Ring’ can be read in the Journey Steps at any time. And under the right circumstances* completed (explain later). It also has a completion text which subsequently unlocks should we do so.

  2. Lore wise The Archivist explicitly states in his conversation with you that you need 7 artifacts, as opposed to the current 6, with the seventh being the ‘Essence of the Serpent Ring’, which The Mummy of the Ring drops when defeated. We only currently need 6 so that people can still remove the Bracelet, see the ending and reroll in the meantime.

  3. The Mummy of the Ring (and his artifact) is already in the game, just not fully implemented. He can be spawned in using the Admin Panel and defeated accordingly now, which hypothetically speaking will log the Journey Step as completed. However, he feels very weak and unfinished, having less than 3000 hp, and only the most rudimentary 1 hit attacks.

*I am also more than happy to provide the Admin Panel code for people to spawn him in if anyone would like me to do so. The Mummy of the Ring is the closest thing we have to a Final Boss in the game. And I would very much like to see Funcom finish working on him and get him implemented into the game.

9 Likes

One of last Streams I watched, (I’m a few behind) and When Jens was still around pointed out Mummy wasnt forgotten, Just not fully finished.

This is one of ones PC users pointed out later, as it didnt do anything in early part of year, by year 2, It was added there was a message when crafting keystone. (that can be turned on by pc modders) which spawns mummy in unnamed city. (if thats it spawn location is unknown)

So its diffidently something staff messed with, and modders took notice year or so back.

2 Likes

I would love to see him fully implemented And the story actually fully implemented to its completion. Maybe it will be added as a dungeon in the future.

2 Likes

Wrong - you need the ring to craft key stone. Archevist and the demon stuff both say that -_-

I vaguely recall reading about this Sera67. There were 2 possibilities I read. One was that he would spawn in with a Purge thereafter using the Artifacts. But the most common one I heard, and which you have touched upon here is that he spawns in the Unnamed City. From what I have read he should appear inside the Temple of Set near Warmaker Klael, where the giant Snake normally appears.

Ya, there video on YT for War maker Klael (couldnt remember his name, so didnt post it) Somebody shared it before.

There was another thread, before update, that made it sound like Mummy was sent to get you after going to set spot. 1+1=2 But were likely missing a few +1 in there. XD

My assumption, from what I gathered about essence and Klael talk about him learning from him(to speak) and then sneaking in.

I “assume” 7 of 7, was us going into ruins behind Klael, finding some sort of essence, (ether via Snake boss,) and having that be good enough. Or they remove Snake, (or we have kill snake) and Mummy of set appears to stop us from getting essence.

Which would fit the in-game message about mummy of set appearing to stop you. And fit lore that was told just outside the place. (since its place of worship for set, and you know…ring of set)
I think modders finding message, and tacting it on to key forge site was a mistake) Likely more has to do with the Area with snakes. Since Klael is right outside talking of it.

I believe I had read somewhere a long time ago that he was to be summoned upon placing the other artifacts into the chaos alter but can’t remember logistics of it… that was quite awhile back

Does anyone have some idea of the exiled land lore? I couldn’t find it anywhere.

1 Like

There no way we can summon mummy in vanila, but there a lot of mods - that true.
And we should not be able to craft the keystone without the ring

It is difficult to find a comple and succinct compilation of it all Aleetoo. Much of it is handed to us in ‘chunks’. I do recall that in the past one member created an amazing compilation and masterful narrative of it. Although frustratingly, I have been unable to unearth it. Two of the best ways to piece it together yourself are to complete the following Journey Steps:

-Chapter 8, Step 7: Discover all of the Lemurian lorestones &

-Chapter 9, Step 10: Discover all of the Giant-King obelisks (loresrones)

It is a big undertaking though. The s3cond is by finding all 10 entries of Razmas Journal throughout the Exiled Lands, which offers some nice ‘lived’ lore. Klael The Warmaker and The Archivist also both offer some nice tidbits also. Aleeto if I can by some miracle unearth this members great compilation I will upload it here. For the meantime, here is a Developer blog which offers a nice read:

1 Like

I’ve always wondered about Razma’s journals. In one of them, she talks about how she is a princess of Shem. In another, she talks about stealing from people like she’s back out on the streets.

Maybe she’s a princess who enjoys sneaking out at night and stealing from people?

Her family was … rrr her dad was killed, so she was thrown out on streets. She went from having it all to having nothing and learning to get stuff.