My character got dementia, and I lost everything

Basic Info:

Platform: PlayStation 4
Issue Type: Other
Game Mode: Single Player
Map: Exiled Lands


Bug Description:

My character was apperantly extremly forgetful.
Yesterday I chucked my Skelos cultist master gear on the bench to repair, and the game prompted me I did not have the expertise to fix it. That struck me as rather odd, considering I should be able to do so, but apperantly my character simply forgot the recepy somehow.

But no big deal, I just used admin mode to spawn a new scroll and learned the recepy again, and carried on.
Today I decided to take a trip to the well of Skelos, as per my normal dungeon run preparation I packed the materials for an improved dismantling bench on my thrall and went ahead.
I was however dismayed to discover that this recepy too had been forgotten, and with no way of regaining it I logged out in frustration.

But I get stuck on disconnecting for about 10 minutes, without being able to access the main menu, frustrated I end up just using the PS menu to turn the console off. This seems to have been a bad move on my part, because now my character has completly forgotten how to exist !
On my next login today I’m greeted by the character creation menu, I restarted the game several times, but still, the game acts as if I’m starting a new character.
Dismayed I create some random char and use admin mode to teleport to my base, everything is still there, but inaccessible to me, as if it was someone elses stuff.

Guess I’m starting all over again, maybe I’ll try Siptah this time around but honestly…This has really put a dent in my will to carry on with this game.


Bug Reproduction:

Sorry, I don’t know how to reproduce the bug.

2 Likes

This is a problem since AoS! Singleplayer don’t save correctly. If you don’t have any backup of your save file there is no way to get your character back. But you can use the ‘no ownership’ option in the server settings menu and then you will be able to use your old base again even if it’s not yours.

1 Like

So you get to roleplay a squatter in your own house.

Somehow it has the subtle sense of a profound wisdom being forced upon you. :thinking:

Thank you, I guess this could do as a workaround, I could also just admin-grant my new character levels to sort of get back to where I was, I am not adverse to using “cheats” to fix problems like this.
The biggest hurdle there would be the loss of journey reward recepies, such as the improved dismantling bench. AFAIK there is no way to spawn them as scrolls etc. From the admin menu like I did the Skelos armor. Or to reset the journey missions. So if this issue reoccurs with the new character… :tired_face:

I’m playing on PS4, and I don’t know how, or even if it’s possible, to access files to make backups.
I cannot even save my game manually.

EDIT: I just tried the “no ownership” setting, unfortunately it only works partially.
The coffer with all my gold is still not accessible, I cannot interact with any placed treasures, my horse or any combat thrall, even my zombies turn their nose up at me…Was a good idea though

Yeah it just doesn’t feel the same, does it? :laughing:
Even if I try to recreate my old character’s apperance and everything, it still would feel off somehow.

1 Like

No. Recreate character yes but remove ownership from your options. This way you will be able to use everything you fixed so far and even pvp with them if you enable pvp. But the bug is bug, annoying and frustrating. I am really sorry m8

Edit. Getting back the stolen is no cheating, it’s justice.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.