Need help, game almost unplayable

I’m not sure what happened to my game and/or if other people are experiencing the same thing right now, but to start off enemies and mobs glitch around the map, I have no real way of knowing where they are at any given moment until I start taking damage, I have to swing my weapons around wildly and hope I hit whatever invisible mob is killing me. Then there’s the stamina issue, whenever my stamina bar depletes it just doesn’t regenerate for sometimes upward of a minute, and sometimes it fills back up but I still experience the black and white screen and can’t run, and it steadily empties again. And lastly placeables just do not load for me. I have to stand in my base (a basic small sandstone base) for 5-10 minutes before the placeables will load, and even then sometimes only the area of the house I’m looking at loads, and the rest stays unloaded. I really love this game but right now it’s actually unplayable and I just finally convinced a friend of mine to play it with me, anyone know if I can do anything to fix my performance issues?

1 Like

Are you playing in single player or a server, and if on a server what is your ping like. You don’t mention your computer specs, they would also be helpful.

I’m playing on an official public server (3827) and I play on ps4. I believe my ping was around 99. I tried uninstalling and reinstalling and it fixed the problem for about 3 or 4 days but it’s now come back

Oh ok, you landed in the pc bug section. It might be worth posting in the PS4 section and seeing if anyone has answers there?

Try reporting here fe3bb1e83d9148a154e7f1ab699c798090c98bcb_2_690x1226 Hopefully a fellow Ps4 can come up with a suggestion also. Personally never had this problem.

1 Like

I have experienced this, a friend on a PS4 also has.

How do you connect to the internet on your PS4? Wi-Fi or Cable?

If you are using a cabled connection , try changing it to Wi-Fi instead.
You won’t believe the difference, and it seems to make no sense logically, but it works (at least it has for me) it’s crazy (having too fast a connection appears to screw things up also heh)

If this doesn’t help, then all I can suggest is look into your internet connection.

1 Like

After you logged out of the game, did you select “close application” on the ps4? A restart usually fixes the glitches.

Have you tried a different server?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.