New animals don't drop heads

Game mode: Online private | Single-player)
Type of issue: Bug
Server type: any
Region: North America

The new animals from the Isle of Siptah expansion are never dropping heads. I’ve tried harvesting them with all types of tools from stone up to black blood and everything in between, even spawned in a maw of the hyena to test with. Have tried with mods and without mods and on both single player and a dedicated private server with no luck. I’ve tried with and without the Island Hunter feat unlocked.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Kill any new animal from Isle of Siptah
  2. Harvest with cleaver, hatchet, or any other tool.
  3. Get anything and everything EXCEPT its head.
  4. Lather, rinse, and repeat ad nauseum and TO INFINITY, AND BEYOND! and still get denied those new fancy trophies.

Hey @Recoilsuave

Welcome to our community and thanks for the feedback.
We’re aware of this issue and it’s been fixed internally, to be released in an upcoming patch not too far a-head.


Thank you both. I wish the bug reports I got at work were half as cheerful to read.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.