No Challenge XP 50x for Booster Event

There is no 50x multiplier on Challenge XP for the Booster event. It worked for my husband Tuesday night and we didn’t even know the event was happening. No matter what I do like won’t change from 10x multiplier. There was another post about it but the OP deleted the content of the post without indicating how it was fixed or what the issue was! So I’m creating a new one. I did the trick I watched on YouTube someone posted who had same issue of going to main screen, selecting single player, then going back to online play and completing a challenge. But that did not work either. Have wasted a Re Roll on it also. Any ideas? Great “fix”. I know it’s not our server because it just worked automatically for another player.

Basic Info:

Platform: Steam
Issue Type: Battle Pass
Game Mode: Online Private
Server Type: PvE
Map: Exiled Lands
Server Name: =SERVER NAME=
Mods: =MODS=

Bug Description:

No Booster Challenge Event Xp multiplier

1 Like

Same here, no xp 50 boost on battlepass. Also, i have all but one for siptha. They really need to make seperate challenges. Ugh why is this game always broken.

1 Like

It’s making me nuts!! They should have just given everyone the BattlePass this Chapter! I don’t understand why there are so many problems with the structural code etc.


Greetings Exile,

Thank you for reaching out to us. Please submit a ticket to our Help center so our team can investigate what’s happening in your account.

Make sure to select “in-game purchase” as the issue type.

Have a great day!

You have to use stored multipliers first. I had 20 to burn through before I got the boost.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.