No Owner base bug


#1

I updated to the latest patch last night , logged in and proceeded to spend the night out exploring. I got back to my base and all my items say “No Owner”. I can still use them, I can even return a door to inventory and put it back up but it still says “No Owner”. I have not joined a guild, I have not tried to start a guild. My main concern is that because it says “No Owner” someone can just walk up and open my place up and steal my stuff.


#2

while i play on a pve server and am one of the admins there i can confirm that we have the same issue with roughly 50% of the buildings , i can also confirm that no one can interact with it unless it was previously yours
also make sure non of the admins on your server don’t remove them builds as this can couse a bug where other perfectly fine builds start to decay


#3

I can confirm this bug is still in game as of 5.3.2018

Devs please give some feed back, Known issues? Pending Fix? Release is just a few days out I hope this fix is in the Release at the very least.


#4

We are having this problem as well new players on our server have to make a clan for themselves to use their own builds


#5

Sorry for bumping this relatively old thread, but it seems this is still happening in Single Player (at least that’s what I’m playing) for when you don’t have a Clan created. I didn’t saw any other mentions of this problem reported, but I didn’t do an extensive search here

Any new building objects you place, they show as No owner when inspected with the repair hammer immediatly after placing them.

I’m gonna try to reproduce the bug in a new game/new character and see if creating a Clan changes the way it behaves.


#6

I will be looking for the results of your testing, I don’t want to make a clan just now.


#7

Welp… I tried, but I didn’t found a way to make a Clan in my Solo game without having another player connected to my instance :frowning: It seems that creating a clan requires you to interact with another player (Hold E to interact on them.)

The Main menu option that I remember existing before, is not there anymore, even after turning admin mode ON. (Hmm… Maybe there are some console commands that I can use :thinking:)

But I haven’t researched other options yet… I was waiting on some of my friends that used to play Conan with me at EA release, to see if they’re able to join me up in solo co-op for a bit, as that’s the easier route… problem is, most of them unistalled the game and aren’t eager to install it again :expressionless:


#8

Thanks for the reply, I really haven’t tried to create a clan since release because of that bug that says I the leader of the clan is offline, when I am not.


#9

No problem!

I promise to report back here if I somehow manage to get more info, or find some way to test it with a Clan. It might take a while, though… still hoping I can convince a friend to install Conan back :grin:

But I don’t want to be too pushy :smiley:


#10

I moved my single player game to a dedicated local server, and, just to be sure, I started building a new base in the highlands of the frozen north area (just to be sure that is not something broken with my existing base).

The No Owner bug still happens. And I haven’t found a rhyme or reason of why some objects are placed with No Owner, while the next one besides has a correct owner. It seems random… no pattern at all, at least that I can discern.

I tried to create a clan… but that invalidated all my already existing constructions… as in, the game let me use stuff I already built and placed, but if I wanted to place a new item, it shows “Land already claimed”.

So, I had to rollback that savegame and keep playing clanless… if I ever try a new game at some point, I’ll remember to create a clan, top prioriy, so I can properly test this again.


#11

After playing a lot over the last week, and also building a LOT too… (built ~2 bases over the last week + weekend) I noticed two things.

  • (1) The No Owner bug doesn’t happen immediatley after a server reset… and if it was happening, a restart clears it.
  • (2) It starts happening after some time after you’ve been building and placing items, not sure if it’s time based or simply the number of placed items.

For me, the bug never happened with placeables, like crafting stations and other furniture… whether it has a menu option to retrieve or not, doesn’t seem to matter.

Also, I never notice it happen when placing walls or frames or doors. It always is with foundations, pillars and ceilings, for me at least.

I wish there was more people sharing their experiences, so far it seems that we’re just two or three people having this issue :frowning:

I notice it because I use Pickup+ and that mod doesn’t allow picking up objects that have no owner. Maybe if people that doesn’t use mods would check with the repair hammer more often and report it here, we could start noticing some kind of pattern… I hope :slight_smile:

In any case, it’s an annoying bug… I hate having to restart the server just because I misplaced some object and cannot pick it up again… specially with how wonky the connections between items are behaving lately :grimacing:

EDIT: all the typos in the world


#12

Well, I have fresh news @SirCharlesEdward :slight_smile:

I finally took the plunge and made a clan on my single player server, and that solved the issue completely for me… so I’m now 100% positively sure that the issue is completely related to not having a clan.

In order to create a clan, I had to do some legwork first, to avoid invalidating all my thralls.

First I created a backup of my save (just in case, to be able to go back to a safe point in time.)

Then, thanks to the mod Pickup+ I was able to pick up every single thrall I had placed (you’ll have to strip them of all their armor/weapon first) and store it in a chest along with their equipment. I had to go around all my bases first to do this on each of them. I also picked it up the thralls on benches too, even if it not technically needed… just in case.

After all of this which took me quite a while, then I created the clan from the game’s interface… which, doh, I wasn’t aware of it before when I wrote my last post about that in this thread.

Basically, in-game, just press I to go to the inventory then pick “Clan” from the options that appear above, then type a name, and hit Enter. But WARNING: Only do this after you’re absolutely sure that all your thralls are safely stored away!!

Then, I quickly checked all my six bases to see if ownership was correcly updated for all placeables, for this I enabled the admin panel and quickly jump around using the map and a repair hammer and checked doors, foundations and stuff… just to be sure all was alright. Didn’t want to stick with a broken game and realize about that much later.

After that round of checks were done, I disabled the admin panel, and proceed to go to each base nromally and started to take thralls out of their chests and re placing them and re equip them… all of it worked flawlesly, thankfully.

I did that mostly during last Saturday, and was playing since, and never once I had the problem of placing an object only to find No Owner on it. And I started building an extension on my base for the map room, and I placed a lot of foundations and stuff… no issues whatsoever.

The hardest part was thinking about a good clan name, in all honesty :smile:


#13