Only volcano event seems to be working

In my single-player game, the only event that seems to ever be active anymore is the volcano event. It’s there evry time I check, but no other event seems to be happening. I’m trying to do the “Defeat a Storm Boss” Challenge, but I can’t do that in EL without the Bridge of Betrayer event or the one in Sepermeru. (as far as I know, those two count, but not others?)


I second this - the old encounters had been removed few days after releasing Chapter 2, but the challenges which can not be completed on EL are still here.

It’s kinda annoying, when you reroll challenges and get the only legendary one with Sandstorm beasts… :slight_smile:

I also found only that one near volcano obelisk and that’s it.

1 Like

Sandstorm Beasts can be completed by killing the sandbeasts outside the Sandswept Ruins.


I play only SP and I can confirm all new witch hunt events are triggering on single/private servers but the old chapter 1 events have stopped spawning.

As for the challenges and the BS of having to complete Siptah challenge in Exiled lands I consider that a bug and just use Admin to spawn in said Siptah bosses and kill them for the challenge completion I just don’t loot them.

Single/ private server


I tried the event in Sepermeru, which spawns the same type of boss as Bridge of Betrayer in Chapter 1, but after several attempts, the event just doesn’t seem to be happening for me.

In SP, leaving the area and returning causes all the NPCs and such to reset, so I assume it’s the same for events. I would teleport between Bridge of Betrayer and Sepermeru. I thought that would make them reset, giving me a chance for an event to spawn each time. But after several attempts at each, no luck.

I did have Sepermeru event happen after Chapter 2 release, but it just hasn’t happened for me recently.

I can’t verify this for certain, but on PS4 official I’ve only seen it in the volcano as well.

1 Like

I’m gonna throw this in. One of my friends gave me a tip-off some time back but I never confirmed this.
In Sepameru in the wine cellar dungeon I believe the last boss is considered a Siptah boss now I don’t know if it’s true but it could be worth trying.
Next time I get the Siptah boss challenge I might try it to confirm if it’s true.

1 Like

You are not the only one @St.Michael. Fellow Offline Singleplayer on ps5 myself buddy. This is what I sent to another just recently:

I really do hate to be the bearer of bad news, but for many members the fix did not achieve the intended outcome. Most encounters are still broken, and I have images to back all of this up. Here is where my game currently lies:

  • A Snake Cult Caravan: still not working
  • Sacriffice Interrupted: still not working
  • Portal to Yuggoth: still not working
  • Grave Matters: still not working
  • Blowback: still not working
  • Head Hunting: in working order, as it was beforehand
  • Witch Hunt: still not working

Pointed this out in test, but with all of 12 people across 8 servers{?}, not enough voices for them to hear us.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.