[PC] Thrall clipping through the ground (finally happened to me)


#1

Game mode: Online
Problem: Bug
Region: US


Finally had the infamous thrall clip happen to me. I have a fishing quarry set up, and it’s ringed by foundation blocks. I put 2 archers up on top of the foundation wall with no real way down for them. Been fine for a week or so but I logged in this morning to find one of the archers (the one closest to the door) swimming in the quarry. I picked him up and put him on the doorstep which is only 1 foundation deep, and he sank in. I told him to follow me and I led him outside onto regular ground which he stood on fine. Then I tried to place him on foundation again, sunk in. I tried a ceiling tile instead and then he fell through the earth.

I had a similar issue yesterday where my carpenter had stood up and gone to the other side of his desk and was staring at me from halfway inside the wall. I believe it had something to do with the aggressive neutral attitude they show players who come through the base on PVE. They don’t attack but they will get in your face. I assume a player came through the fishery and my nosey thrall tried to follow them inadvertently granting the thrall noclip of some sort and the meathead can’t turn it off. I notice the same type of clipping when I ask a combat thrall to follow me and they walk through foundations and walls to get to me.


Steps on how to reproduce issue:

  1. Place a thrall on a foundation piece, or any building tile it seems with no pathing to the ground. (In this particular case it was a sandstone foundation)
  2. Speculation: Have a non-clan member walk nearby and catch the thralls attention?

#2