PlayStation Update 2.4/2.4.6 Official Discussion Megathread

I’ve done the testing for you. Nudity is not working. The server says it has full nudity option enabled, but the game settings have only two options: none and partial (both in single player and on official servers).


Is there a way yet to move your character between the two maps ? Do you still have to pick one or the other & lose your buildings/progress when you switch in single player? I primarily play single player on pc, but also play on PS4.

Where is this searchbar? It would be so nice if I can put in a text in the crafting Menu. It would save hours of scrolling and I was so excited when I read about this :joy:
I have connected a keyboard but I don’t find where I can do my inputs also no focus on anything like that

Edit: the checkbox in the gameplay menu is there but nothing changes when I tick it


I cant find an IoS server. Does anyone else have this problem? :sunglasses:

Mam pytanie ! czy serwery PvE conflikt EU naprawiono ???

i bez problemu można wejść ??? !!!

Just wanted to offer a tiny amount of feedback on the Siptah release.
Thank you for leaving the initial release price point at the same rate as it was for those who had the opportunity to jump on the early access. I, for one, appreciate it. My personal opinion is that it’s a good gesture towards parity for console players.

Every new roll out is going to have bugs and hiccups, that’s to be expected. I was honestly going to wait until the first post release patch before considering purchase of Siptah. But y’all matched the early access tag offered to PC users, so I find it reasonable enough to go ahead and put some cash down on the initial release.

TLDR; Price point parity is particularly appreciated by this player.

Still no nudity offline solo


Are these and other points in the patchnotes for PC? I saw this function on YouTube for pc but I don’t get any searchbar I can input. Only in the adminmenu there is an inputfield

1 Like

Thank you for pointing it out. We have removed the line from the Patch notes.

We apologize for the confusion.


Regarding the Nudity issues, we are currently looking into this so thank you for being patient with us.

In the meantime could you please provide us with some additional information?

Have you purchased a digital or physical game copy?
What region are you playing from?
Are you only seeing the options None and Partial under Nudity? Easiest way to see this would be in single player.


Coal is bugged.
If you hit it, you only get one harvesting, and the coal wont be destroyed and the new spawned breakable harvesting object wont spawn and be harvested.
This is for most coal nodes.

There is also ghost colliders still present after you have harvested a rock/stone. There isnt any mesh , but you walk into something that pushes you back. Like an invisible collider that hinders you from walking in that area. What i remember is that i harvested a rock/stone there before. Could be a server lag, but the problem stays for over an hour. Or more. The server lag, i mean that im playing on an american server but im in europe. That it could be a communications error, that my client dont get the collider info while the server has the info. Or the other way around.

The graphics have taken a massive backwards step with this update. Now things in the far distance have a fog like effect which looks weird. The river textures are also awful and make you feel seasick when running.
The purge is even more broken. Didn’t even get a purge notification last night, only found out about it from checking the event log to see npc’s were destroying foundations. The purge then bugged out midway through the second wave and cancelled.
The climbing animation is painfully slow and makes any long climb tedious and boring.
Npc’s are invisible quite often and you only know they are there when you run them over on your horse. This also applies to clan mates as my clan mate appeared to me as invisible on his horse and his thrall could only be seen by a floating sword.
Building and structures now take even longer to load in, it took 30 seconds for just a basic maproom to load in.
Oh and loading times through dying and teleporting are ridiculously long.
These are just a few quick observations, I havent tried the fighting (ahem) improvements yet but it looks like you have broken the exiled lands in order to get people to buy siptah.


Ok thx. But if its possible to put it on a list it would be a very nice feature in future :slight_smile:

FYI the setting option in the menu is there on ps4.

Got some additional information from our Dev team.

The nudity fix did not make it into 2.4.4 but it will be added in our next update for PlayStation.

Thank you for your patience and understanding.


Not the most important issue to fix imho =)

Apparently important, if so many players keep reporting it

1 Like

Man, what to say. Really really thank you!!! :smiley:
You developed a huge update, but I’m happy only about this!!

Graphics are nowhere near as good as before 2.4 I’m afraid. I’m on ps5. The water is white and looks horrible, as I’m walking around my base I can watch little details rendering in every time I exit and enter a room and it looks horrible. It was absolutely a much better looking game before 2.4. Not sure what you guys have done but it’s gone downhill for sure.


No clue what they’ve done, but it sounds like a lot of us with the PS5 are experiencing this issue. Game looked beautiful before, now looks horrible!