Please! Can someone Help?! My game keeps Crashing! [FIXED]

I have been playing on this official pve conflict isle of Siptah server for a little over two weeks now (8060). and for the last two days every time I try to join, I am met with a crash error code after about 3 minutes of loading. I have tried literally over 100 times to join. 

I have tried many things to get around this. I have had my friends kick my body, I have had my friends kill my character, I have tried separate accounts, I have reset my internet, I went onto other servers just to see if I could connect (and I had no issues connecting to said servers)  I have reset my playstation. 

I am at my wits end. I have no other way to play, and I cant help/play with my friends anymore. 

Is there any solution??

I might be the biggest moron ever!!!

So it turns out the problem I was experiencing was the DLC map itself.

I had previously downloaded the content and was playing on the game just fine for a few weeks.

But after going through my available content for the game, I saw that the isle of Siptah had its download icon un-grayed out. So I clicked it, and it turns out, I had a 2GB update that hadn’t automatically updated for WHATEVER reason. Causing me to crash repeatedly for seemingly no reason.

kinda weird fix, but maybe someone else had this hyper specific issue as well. Good luck my barbarian bros. and thank you for your time


Welcome to the Forum @ShutUpLetsFlex . If you start a club for technically challenged people I will join. Glad you fixed it. Have had to go through the download process over on ps4 and so have others.

1 Like

Well done m8, have fun :+1:t6:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.