HELP Still cannot play on Siptah! 3 mths and climbing

Basic Info:

Platform: PlayStation 4
Issue Type: Crash
Game Mode: Online Official
Server Type: PvE-Conflict
Map: Isle of Siptah
Server Name: 8121

Bug Description:

Since first new update won’t load, tries to then crashes within 10 seconds same since 2nd update also I am worried about losing my base etc

Bug Reproduction:
simply tried to log into my game

1 Like

Just checked , yet again, STILL cannot log into my Siptah server… neither can my team mates on a ps5 with better internet the other sdie of the world!

Thankfully one of us can, on a ps4, to render, but it’s not a team fun game if the rest of us cannot join in, please please advise and update…


@Community. Do you have any suggestions for our friend here?

1 Like

Suggestion go to play store and attempt to reload Siptah on to your playstation it has worked for people before don’t know that it still does but won’t cost anything since you have purchased it already :grinning: @MibsXX

tried that 4 times now lol but thank you anyways x

1 Like

Can not say what is up we were on private Isles of Siptah yesterday. @MibsXX @Community can you help our friend out. Thanks in advance.

Many thanks sestus2009 for your continued support… just tried yet again, still cannot get past the loading screen… re-installed it yesterday too , again. Friends also tried all suggestions and they cannot load in either, ps4 and ps5’s.

Please @Community

could you give some sort of timescale of when this will be fixed

1 Like

Greetings Exile,

Thank you for reaching out. Your case is still being investigated by our team. Unfortunately, we don’t have an ETA to provide you with yet.

Apologies for the inconvenience.


Can I make a silly question here @MibsXX, why do you play pve-c, you like the conflict between players? Please make no assumptions :innocent:, it’s just a friendly question!

1 Like

@stelagel has a point see if you can get on pve seems to be a problem with pve-c server’s. @MibsXX


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.