Purchased DLC is not accessible to me

Game mode: [Online | Singleplayer]
Problem: [ Bug | Performance | Misc]
Region: [Oceania]


I have just purchased every DLC available in the PS store, only to find out in the game that I cannot access any of it at all. Before anyone has anything to recommend I can assure you that I have tried everything from: Reinstalling the game, Restored Licenses [Multiple Times], Rebuilt Database [Multiple Times] and deleted save files.

I am currently in the process of contacting Sony if it’s something on their part, I guess some minor details I can provide for now leading up to the point of purchase is as follows: I live in Australia [Oceana], I purchased $50 worth of PS points at a store to then purchase all the available DLC [Year 1 Bundle, Treasures of Turan Pack], then found out I can’t learn the feats to build or craft any of the DLC which is always marked with the green arrow on the icon in both Online and Offline modes. Everytime I go to the PS store to view any of the DLC it says I have purchased it already. This has happened yesterday, todays update hasn’t fixed it btw.

If any devs could point in the right direction that would be greatly appreciated, I can provide screenshots but this would only confirm what I have been explaining but if it’s needed please tell me.


Just to confirm. In order to use the building pieces you need to unlock the regular t3 building. In order to craft the armors you need to unlock the regular armor feat and so on. In order to craft the placeables you need to craft the specific artisan bench.

I can confirm I have just tried this method and still to no success, still seeing the green arrows. I can’t even admin spawn any of the DLC gear in a offline game.

Hey @Grimsonred

We recently had another user report a similar issue, and it all boiled down to them having a physical retail disc from another region. Please make sure that the region of your main game and your store DLC match to avoid this issue.


Thank you! The physical disc is from a different region, I will ensure I get the same region copy which is an easy fix.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.