Season 2 Pass Broken Again? (SOLVED)

Game mode: [Online]
Problem: [ Bug]
Region: [America]


Okay, so I purchased the Season 2 pass and the Conan statue DLC. None of the DLC stuff shows up. I have purchased DLC stuff before (Savage Frontier) and it worked fine. I see all of the skins for my animals, the construction pieces…everything. Now I purchase the season pass, then go back to the PS Store and click on the “free” Turan pack and it says, “thanks for purchasing” but nothing is available in my crafting, it’s not available in my “feats” nor is anything available at the Artisan Bench for the “Riddle” DLC. Even though THAT one DOES show up in my “feats” and IS green.

Any thoughts? I’m not sweating it because I got this game as PS+ free and felt it only right to purchase the DLC since I’m so addicted to this game…I completely understand bugs though and thought you should know about it…again.

P.S. Should add a DLC tag to this forum.

There is a thread that discusses this issue saw it couple of weeks ago.

Here is the above mentioned thread.

As for the riddle of steel the placeables are all crafted at the artisan table, helmets at the armorer and body paint at the firebowl. You do have to learn stone throne for the DLC throne.

Yes, I’m aware. That thread is closed and says it’s fixed…It is NOT. It’s also from back in April.

Apparently, you read only my title. Please read the full post. Those steps do not work and none of those things are craftable nor do they even show up as unlocked - as I said in my post.


Try the above for the DLC content if possible.

Try suggesting it to @AndyB.

I did this. It said failed to spawn…Then I searched again, it doesn’t even show up in the search.

Not sure if Ignasis is refering to what I’m about to link (as there might’ve been new fixes);

See the second notice at the top of this page https://conanexiles.gamepedia.com/Downloadable_Content
Try doing this. It might not work, as I have experienced it not doing so before for other users, but it’s worth a try.

SOLUTION FOUND!
So it appears that the PS4 licensing stuff can become a little - we’ll say - cluttered.

Restoring the licenses locked my game. It suddenly had a PS+ icon with a lock on it. I checked my membership and it was all good, saw all the downloads and purchases in my library and still nothing. Suddenly, I was getting “Application cannot start” and an error code.

A quick chat with Sony support and they had me deactivate my ps4 from primary then re-activate it, THEN restore licenses.

Now EVERYTHING is working and appearing in my crafting locations where it should be. Hopefully, this “licensing / activation” issue will help someone else.

4 Likes

Awesome bro, thank you sooooo much :+1::sunglasses:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.