Server Transfer Broken - No Option to import character


I just attempted my first character transfer. Unofficial to my own personal Unofficial server. Followed the instructions perfectly for uploading my character from the old server. Made sure I deleted my character on the new server and, through trial and error, figured out that there is a ServerTransferEnable button in the g-portal settings. I turned that on and rebooted the server.

However, I’m still not getting an option for character transfer in the character creation scene.

What am I doing wrong?

Where was my character uploaded to? Is it a local file or is it uploaded to some Conan server somewhere? Is it possible to recover if I completely dorked this up?

Try to restart your computer and steam. Server transfer was not enable on your server, may be some cache issue.

If it still dont wort, try to transfer to your old Unofficial server.

Okay, so, I tried all that and I’ll put together a more comprehensive diagnostic of the problem. Firstly, a simple reboot of the PC and, with it steam, did not solve the issue.

When I attempted to rejoin the same server I uploaded my transfer from, I did get a different menu with an actual button recognizing the import feature but it said “Cannot Import Character”. I assume that’s because either the old server has the feature “CanImportDirectlyFromSameServer” is disabled, or because 24 hours has not passed. However, thank you for this tip because at least I know now what that first screen should look like.

I’ve attached images of my server “New Server” and the previous server “Conan Old Server”. You can see from the pictures that my server never even gives the option screen for importing a character and simply goes into the default character creation screen.

I’m trying to figure out why my server seems to be blocking the feature, whereas there is clearly an import character available and the ServerTransferEnabled feature is set to true (can be seen on the g-portal server settings page as well as the settings.ini file).

For further clarification, both servers are PVE, both are unofficial servers.

New Server

Old Server

New server running IQoL mod? Not sure if the issue was resolved but this was one of the mods that would prevent the import button from showing up. The char creation of the first screenshot is not the default one for sure.

It actually is running Improved Quality of Life 3.4.6 … should I try to disable that mod?

Aye yooooooo! You’re a god amongst men. I removed that mod and the option is now available.

Welp. Now I have a new problem. I clicked “Import Character”… got a processing screen… then it kicked me back to the main menu. I rejoined the server, and after an extremely long load time… it just kicked me back to a character creation screen.

after I rejoined I just get this

Future person reading this, getting rid of the IQOL mod definitely fixed the problem of not getting the option to import. Why my upload failed with no error message and is giving me the default character creation screen now?? Well… I guess that’s a topic for another thread.

The feature is designed for officials. You are running mods. Not sure whether your mods are matching the ones from the old server but the transfer might not work well or at all with modded characters. I think Funcom had a disclaimer on it.

1 Like

Yeah I think at the very least disabling all mods before exporting and importing would be imperative. Of course disabling mods might well make the game unplayable but that’s always a risk when running mods.

Unsure how this would work though, Mikey. If you disable the mods a lot of stuff may go poof with the only solution to restore from a back up which would not have your character.

1 Like

Agreed, and that’s worth mentioning for sure (it seems obvious to me, but it probably isn’t, really, to the average user).

I’m not sure that server transfer for modded servers is possible at all, unless some of the mods allow for that functionality especially, which is what I was hinting at above also.

Yeah… my character I’m importing has AoC armor and weapons. In my inventory I have a lot of AoC materials. I assume they would disappear if I disabled all mods. It might be worth disabling unnecessary mods tho.

I think it’s certainly worth disabling as many mods as are possible (ie, ones that don’t invalidate the character when removed) in order to maximize the chance of the transfer feature working.

It’s probably always going to be a risky endeavour at best to run modded and use transfer, though. That said unless one is a serial transferer, losing a few items here and there should probably be considered “the cost of doing business”.

Removing (dismantling) modded gear and rendering it down to vanilla-only items in advance could likely somewhat mitigate the issue (same as one would dismantle one’s base prior if wanting a running start).

Update: After disabling all the mods other than the essential ones to keep my equipment (essential mods: AoC, EEWA, Kerozards Paragon Leveling - Reloaded), I’m still unable to import my character. No option available now.

I thought about starting another topic but since someone else may experience these same issues, I’ll keep it here. Today, after 24 hours… I got the Import Character button again on my server. Only this time, the import character has no steam ID and the level is all over the place. The first time I tried it said 446… this time is says 40. My real level was 178. I feel like my import may have been corrupted. Any tips out there?

…and when I click import I get this gem

Update: my friend who was on the same server as me… who uploaded his character from that server at the same time as me, and who was attempting to join my server…just tried to transfer his character …

…and it worked for him. in 2 seconds. So I guess I’m the lucky one.

I’ve been reading this thread about your troubles importing your uploaded character and what worries me the most is that people can end up with a stuck character that they cannot import to any server which may block all future transfers even for official servers.
This to me feels very unsafe and not optimal, there really should be an option to delete an uploaded character as a last resort, Funcom really needs to address this and give us options in case something goes bad.
Although we also tried to find a way to transfer characters between private servers since we were playing on 3 different maps on one server, we wanted to switched map every 2-3 weeks, but was hoping to use the same characters by transfering them between the maps(server backup).
We never really found a good solution to it while keeping our bases, so it never really became a thing, and with your experience I am glad that we never attempted it seeing how easy it is to mess things up to a point where possibly could have ended up with a stuck uploaded character!
Bottom line is I hope you find a solution to your transfer problems :slight_smile: