Shattered Scourgestone Piece not Dropping

The Shattered Scourgestone Piece is not dropping for me.
I have cleared the pirate shipwreck camp multiple times. I have killed Gall 'o the Spear-din and Hekkr Waverunner multiple times and nothing.
Anyone else have this happened to them?

Game mode: Online, PVE server (3758)
Problem: [Bug ]
Region: NA

[Free text]

Steps on how to reproduce issue:

  1. Kill Gall o’ the Spear or Hekkr Waverunner
  2. No stone piece found
1 Like

Hello @crsito15, welcome to the community and thank you for your report!

The team is already aware of this issue, it should be addressed in an upcoming patch.


oh good! I thought I was crazy or something hahaha!

1 Like

The First Mate has been dropping the scourgestone piece for a while now. She’s on a platform right before you go up to the Captain’s Quarters.


I have also had random Black Hand Fighters along the beach south of Flotsam drop it too in recent times.


oh weird! I haven’t had that sort of luck lol

As of Oct 27th I still can’t seem to get it.

Thought they was supposed to be fixed in the last patch, seems it hasnt though. Really sucks considering it makes it impossible to try fro the black yeti pet. Any news on this?

1 Like

and ironically about a month ago I had like fifteen of those damn pieces, and I can not remember where I put them lol

Any predictions to fix this bug?

OK, so yesterday I ran through Buccaneer’s Bay to see if the thing is still there. I was on an official server, 3890 PvE. The first trip through I found Udnina sitting in her usual spot, killed her, and took the stones from her body.

I ran and slaughtered Flotsam, the animal tamers, and Huey the giant broc before returning to the ship. Udnina was not in her usual spot. Gall-O-Spear was there instead, and he also had the stones.

I have been told by players on the server that they are not getting the stones when they go, so I don’t know if there’s something about my game in particular that I keep getting them, but I dropped them on the ground and the bag was empty when I looked in it. I can put them in a cabinet, but not on the ground.

So that’s new.

1 Like

@FabioARO It should be addressed in the upcoming patch, no ETA as of yet though!

@speedice Thank you for sharing your findings, post-fix this item should drop on every attempt rather than being inconsistent as it currently is.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.