Since the latest update, I get a "Fatal Error" when trying to log in

Game mode: Single-player
Type of issue: Crash
Server type: Solo Player
Region: [ Please enter your server region ] N/A
Mods?: [ Are mods installed: Yes | No ] Yes Then Removed Them
Edition: [ Steam

Bug Description:

I have been trying to log into the game and get a “Fatal Error”. I have removed all of the mods and it still occurs.
A clear and concise description of what the bug is.

Installed Mods:

If you answered ‘Yes’ to using mods, please list all your active mods. Otherwise, skip or delete this section.

Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Step 1 - Login.
  2. Step 2 - Receive “Fatal Error” message.
  3. Step 3
  4. Etc.

I am having this same issue.

Same on a dedi server and removing the mods and fresh server install solved the problem. Probably a mod conflict which FC can’t solve but if you could post the modlist, perhaps those of us with the shared experience can nail it down.

1 Like

I removed all of the mods and still got the “fatal error” message. Ever since the stam adjustment back in the spring, I have had all kinds of issues like lag, rubberbanding, etc.

Yes I’m aware of that which could be a bunch of dead mod references that still cause your game to fatal error. Your modlist could still be useful for tracking down the problem.

One of the 1st things I did was to check on the mods and they have been updated within the last month. I’m going to try to reverify the game after I copy everything.

20211202000330_1 mods 01
20211202000353_1 mods 02

So you and I have two in common out of your long list and my long list; bosses be thrallable and pippi. My hunch is now bosses be thrallable…

It isn’t either one because I just reloaded the mods without Pippi and Bosses Be Thralled and still got the “Fatal Error”.

Yes but something could be corrupted. I dont believe its Pippi but BBT hasnt been updated since Sept. Makes me suspect it. At any rate, fatal errors Pippi and BBT are what we have in common, and a clean wipe without BBT on my server fixed my problem, albeit by losing all my game data. Perhaps others with Fatal Errors will have more to add.

TBH, I don’t want to start all over again. I had to do that when Siptah was added and now like then I have too much time and material invested in the game. I am getting tired of this.
I have run the file validation 3 times and Steam has not found a issue so I just don’t know.

Try this. Save your database as a backup, start a new game and get it running again. Them load your backed up database again. That should let you know that its a mod and not base game.

Or better yet, start a new game on the other map. Your database on the other map should remain I believe.

I tried the uninstall/reinstall thing and still got the fatal error message.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.