(Steam) Dedicated Server crashes on start-up

Game mode: Locally hosted Dedicated Server
Type of issue: Bug/Crash
Server type: PvE
Region: n/a
Mods?: No

Bug Description:

For the last few weeks I’ve been playing on LAN, on a dedicated server I’m running. There’s only two players, myself and another person.

It’s happened two or three times before that on start-up the server will crash shortly after the launcher pops up. The fatal error that happens each time seems to always be the same, something relating to an instanced mesh/actor:

[2022.10.09-23.38.04:785][  0]LogWindows:Error: === Critical error: ===
[2022.10.09-23.38.04:785][  0]LogWindows:Error: 
[2022.10.09-23.38.04:785][  0]LogWindows:Error: Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\Engine\Private\HierarchicalInstancedStaticMesh.cpp] [Line: 2295] 
[2022.10.09-23.38.04:785][  0]LogWindows:Error: Invalid InstanceReoderTable Index 32 of 0 elements in UHierarchicalInstancedStaticMeshComponent component 'PickupFoliageComponent_C_35' of actor '/Game/Maps/ConanSandbox/Art/Heightmap/Heightmap_x2_y4.heightmap_x2_y4:PersistentLevel.InstancedFoliageActor_0'
[2022.10.09-23.38.04:785][  0]LogWindows:Error: 
[2022.10.09-23.38.04:785][  0]LogWindows:Error: 
[2022.10.09-23.38.04:785][  0]LogWindows:Error: !0x0000000000000000
[2022.10.09-23.38.04:785][  0]LogWindows:Error: 
[2022.10.09-23.38.04:789][  0]LogExit: Executing StaticShutdownAfterError
[2022.10.09-23.38.05:211][  0]LogWindows: FPlatformMisc::RequestExit(1)
[2022.10.09-23.38.05:211][  0]Log file closed, 10/10/22 00:38:05

Usually we have been able to side-step the issue by reverting to a slightly earlier backup of the automatic game.db backups. Using the built-in CheckGameDB batch file always reports that all the .dbs are “OK”

We have put in almost 48 hours into this save in particular, and it would be quite annoying to lose it entirely, because none of the auto-backups are stopping the issue this time. What doesn’t make sense is that even backup .dbs from before the latest crashing issue began, still cause the crash to happen this time.

We also don’t even know what’s causing these crashes to happen because when we exit the game and close the server, we’ve usually had it running for a few hours each time, all the while it’s been fine with no issues while we play. It’s only on starting up again later that this issue will happen.

Installed Mods:

(no DLC either)

Steps to Reproduce:

  1. Launch and play on our dedicated server
  2. Exit the game and close the server
  3. Later repeat step 1. only for the server to crash on start-up

Have already tried verifying all of the server’s files and used all the built-in tools to check for corrupted files. Everything appears to be “OK”.

I can provide the .dbs and full logs if this would help diagnose/solve the issue.

We have kind of half-solved this… We used the built-in server-cleanup tool that removes all non-character data and noticed that the server wouldn’t crash anymore.

However, we weren’t happy with losing all our bases and thralls, so after a lot of fiddling, we manually opened the game.db and through much trial and error, found out there was an offending foundation actor causing the crashing issue. When I went on the server and checked what this removed foundation was that really caused the issue, I found it was the location of a most recent bridge we’d built across a tiny river on the north-west tip of the map. Come to think of it, I remember at one point the server had crashed during normal play while this bridge was being built, so it’s possible that crash caused the issue.

I don’t know how things work on the UE side of ConanSandbox or anything, but based on the error and the fact that foundations are supposed to remove/prevent some environmental stuff, I suspect that something went wrong with the few grasses near this bridge’s build location.

Greetings Exile,

Thank you for your report. Could you share with us the coordinates of the mentioned location?

We await your reply.

In the affected game.db, the coordinates for the foundation that was causing the problem were these:
x: -176434.140625
y: -50687.078125
z: -4910.42431640625

The in-game coordinates are more less the same. I’d also post a screenshot showing the area/map but am unable to due to “new user” restrictions.

Would you like a copy of the game.db that’s still broken?

Edit: Here’s a couple of screenshots of the location too.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.