Steam Stops downloading at 93%?

Game mode: [Enter game mode here: (Online official )]
Type of issue: [Enter one of the following: Performance]
Server type: [Enter one of the following: PvE]
Region: [United states, midwest]

[I cannot complete the downloading process of the main game in steam. I’ve been able to download the game fine in the past, currently cannot finish the reinstall]

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. I’ve recently deleted conan exiles
  2. Ive tried to reinstall (i’m playing on laptop and installing on external drive)
  3. At least 3 times, I’ve stopped at 93% It times out and when I resume it won’t go any further
  4. I have plenty of space on the drive

Most likely it’s a Steam issue. I had similar troubles re-installing Ark last week. Steams servers have been under more stress than they can manage since the end of last year. This past few weeks hasn’t helped anything, and the “fix” I’ve been noticing is that Steam is heavily throttling client downloads. (It literally took me two days to get Ark re-installed after a borked move because the downloads would just stop.)

You can try changing locations in Steam, and that will sometimes kick start it for a bit, but chances are that you will just have to be patient. The infrastructure of the global internet is under more strain now than it ever has been before.

I wonder. I’ve been able to download and reinstall multiple other games. Conan stops at 93% exactly each time (3 x now) I’ve tried to re-download.

I can’t say 100% but I’ve been able to download any other game on the drive, from steam.

Thank you, ill check it out.

Some times the download of the game stops I’ve had that problem for years and it can do it at 100% to just update it and leave computer running I believe it’s downloading something related between steam and the game when you view the download process you will see a blue bar under the numbers on the left side I don’t remember what it exactly does but it is something in steam that is download but it just a process it goes through

Just an update. There error I get is a “write error” with environment.pak

Verified your files if that does not fix it then look it up on google some one could have found a fix or steam would so try that and see if it works

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.