Still almost impossible to place Wheel of Pain on Wedge foundations

Game mode: Online official #1025 (And single-player)
Type of issue: Bug
Server type: PvE
Region: EU


It is close to impossible to actually place larger objects on wedge foundations. Specifically a Wheel of Pain. I have a hexagon that is 6 wedges across, and then build three square foundations out from each side of the hexagon. The wedges between the squares are then filled with more wedge foundations, resulting in a 12-sided structure, which is about 12 foundations across.

Like this:

It seems that the material used is irrelevant for this issue. I have tried switching the foundations out with ceiling wedges, which also did nothing to help.

The issue is that it is close to impossible, as in I have not been able, to place the wheel of pain on this foundation. I move it around, I turn it, I raise and lower it. But no matter what I do, I get the error: Not Aligned Enough With The Ground.

Occasionally I get an error saying: Overlapping with another object or terrain.


The terrain below the foundations is fairly hilly and the entire structure is a single layer on side, but close to three layers on the opposite side. I suspect that the underlying terrain somehow influences the placement.

I can place a greater wheel though, but it is skewered in relation to the center and thus is not an option.

The walls and especially workstations might be working against you pull the workstations temporarily and try again the next step would be remove walls but those don’t seem to be close enough to interfere. Have that problem with maprooms all the time wonder if last few patches have transferred that difficulty to wheels now.

I recreated the issue on singleplayer, where I had neither walls nor workstations. I do not see those as a problem.

I’m experiencing the same problem but with the Greater Wheel on PS4.

Only thing i can think of is it cannot figure out the center lock points on the wedges. Weird question, have you tried moving it more right/left of the center point?
What we see is flat terrain when all the wedges/foundations are connected, but what the game is looking for in code is lock points. most structures of horizontal lock points (edges), and vertical lock points(around then edges and exact center). Wedges have always been skitzo with its center vertical lock point when trying to connect anything non wedge like. So it may just be that, and may take a little luck to lock it in. But it definitely is a bug no matter what the reason.

I do a lot of shifting and up and down I try not to get it going at angle the up and down part is tricky sometimes. should have asked is there mods on either setup.

Hey there, I have just tested it twice on a private server, and once in SP. I have been unable to duplicate your issue. Both times on MP I built the wedges outward from the center ring (hexagon).

Flameblade, could I suggest a different layout for the foundations? It has worked for me for a maproom on a third floor.

Build a center ‘circle’ from wedges, two blocks wide. From that point, extend 6 radial square foundations for three blocks, giving you a total width of 8 foundations. Then, fill in the rest with wedges. The structure is essentially the same as you depicted, but the stability is enhanced. I have verified this on a roof with the repair hammer. Do not add walls yet.

See if placement works on that, perhaps in solo with sandstone.

For maprooms, you are using almost the entire structure and it’s hard to place, and a bit tedious, but possible. Horizontal movement combined with rotation ‘finds’ a placeable location.

If that works, you can add walls or extend the circle, or add archer stands to the external circle. Mine was a maproom on a two floor building, clan access to the room underneath, public access to the maproom with an external stair set, if possible, leading to water deep enough to discourage purgers.

Good luck, and let us know if this is of any help !

Regards

jim

No mods at all.

I managed to get a greater wheel positioned almost at the center, which will have to do. But no matter what I did, I could not get a wheel of pain to fit.

I realize that there are snappoints, vertices, edges etc. but no matter how you look at it, and no matter what technical explanations there may be, it should be possible to place a wheel of pain without any fuzz at all, as the area is flat.

It’s not just triangles. It’s trying to align to the ground underneath, instead of the foundation blocks you’re putting it on. This has been an issue for a very long time.

had similar issue with wheel of pain, I could not place it at the center no matter what i tried, eventually I left it touching the border of the central triangles (hexagon)

I have rebuilt in many locations in order to test this out. The only way I get it to fail is if I do not build outward from the center ring of six. If you do not build outward in circles, you run the risk of orienting one of the wedges in the incorrect snap point, thus breaking the connectivity of the giant field of wedges.

May I ask why people are building like this? If you transition to squares after you build the central hexagon, you end up with much better stability and none of these issues.

well I for one wasn’t aware that it matters I’ve build starting with one side, then simply layered following triangles line by line until I got hexagon, but as I understand proper way is to do a swirl instead… interesting

Hey there,

We’re aware of some difficulties when building on top of wedge foundations and our team will look into it, although it’s taken the back seat while we’re working on more critical issues at this moment.
Thanks for your feedback.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.