Sword training emote not found post unlock

Official server 2880
Xbox series x
I just unlocked level 3 on battle pass and got the sword training emote but i cannot find it in any emote menu so it appears it didnt work properly.

1 Like

Press de emote button while handling the sword


Thanks I pulled out sword, saw emote, selected it and now it said “cannot emote in your current state”. :frowning:

Now we’re facing the same issue… I’m experiencing the same thing in my game. I play on PC.

Greetings Exiles,

Have you tried to equip a one hand sword and then try to use the emote on the emote wheel?

If so and you’re still finding the same issue, please send us a screenshot so we can forward it to the development team.

Hope you’re able to use the emote and keep conquering the lands! :slight_smile:

Same issue here, getting the “cannot perform in current state” message

1 Like

I am having the problem when I equip a 1h sword and then the emote button, and click sword training. it just keeps telling “cannot emote in your current state”

so i removed my bracelet, and now the emote is working. have to die to use this emote :frowning:


My clanmate @Marylambs had the same issue on PlayStation. I could do it just fine. Oddly enough, she couldn’t see me doing the emote on her screen either.

1 Like

Today it started working

And now it isnt working again. :frowning:

1 Like

Lol unlocked the new weapon twirl emote from battlepass today, and it also giving same error message now

1 Like

It seems to only work with certain swords. I tried using the new Stygian Commander Khopesh, and it doesn’t even appear on the emote wheel, but works with a Longsword.

*Edit: After some quick testing, it seems to work with every sword except the Stygian Commander Khopesh

Still wont work for me

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.