Thrall cant be sacrifice nor can i put the preust thrall in shrine

Basic Info:
Platform: Xbox One
Issue Type: Gameplay
Game Mode: Co-op
Server Type: PvE-Conflict
Map: Exiled Lands
Server Name: =SERVER NAME=

Bug Description:
Can’t place preist in shrines I put them in wheel of pain and then I try putting them in a shrine and they won’t go in

Bug Reproduction:
I put the thrall in the wheel of pain then I removed him when he was ready and I tried putting the thrall priest in the shrine happens on almost every server I go to and it won’t let me sacrifice any other thrall but the shrine won’t let me put the priest in

Are you attempting to put say a Set priest in a Set alter? If you are actually sacrificing some npc do you put them in a wheel of pain first I ask because of lack of experience with Sorcery? @Abyss978

• If you are trying to sacrifice someone at the sacrificial stone, you do not put them in the wheel of pain first, you drag them directly to the sacrificial stone with your bindings.
→ You cannot perform sorcery rituals while over-encumbered, just something to check.

• Now for the priest that you tamed in the wheel of pain, which are thus now in your inventory, you should be able to place them in their altar.
→ You need to make sure that the priest and the altar religions match!
A Set Priest will not work for a Derketo Altar for instance.
→ You need to drag the priest to the proper spot manually, afaik they changed the auto-slot to if you’re auto-transfering them from one inventory to the other, the priest will not automatically go into the slot at the top.

That’s what comes to mind for now :snake:

1 Like

Yes i followed all the steps none have worked

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.