Thrall falling under terrain when dragging


#1

As the title says, thrall are falling when i drag them. They sporadically fall when I knock them out but the dragging just happened to 6 thrall in a row. It happens right outside the stygian city. I tried different routes and still the same thing.


#2

This is for PC btw


#3

Hello,

Same thing happening to me.

It feels like when a “zone load” is happening, the thralls just fall down into the map and get stuck/lost.

If you have thralls that are closer to your base, and do not required a zone change, you will be able to get them to your base.


#4

We will assign a Dev to look into this.


#5

Yup same problem here, on single player. Happened when I tried dragging a blacksmith/carrier from the spot just east of set trainer and a taskmaster from the camp with werewolves just north of the rhinos. Base is at where the river T is so not that far. Had to build extra wheels of pain…


#6

When I have knocked out thralls unconscious on PC version, private server they fall through the ground. I either have to relog for them to reappear or simply wait. But I am an impatient slaver :wink:


#7

i tried relogging. does nothing


#8

I just tried kiting the thrall closer to my wheel and the end up disappearing as well. That last patch really messed things up. There’s now nothing for me to do but stare at my empty base.


#9

Same thing happening here, dragging from the center desert area here the ostrich / emu type birds are down to the south by the water. Get to pain wheel and the rope is just stretched super long back up to where the prisoner appears to have fallen through the ground. :frowning:


#10

Same here. Reported this on the testlive thread this morning.


#11

same here, just tried 5 times with different routes.

Last two times I even cut down all the wood and smashed all the rocks that might be in way

no joy


#12

I’ve lost thralls on the same route, while others have worked. I wonder if it is related to the zone change, or rather physics and what is in your path. For example, I have noticed branches and inclines seem to be nearby, so perhaps they (and other objects) are the cause to the issue?

I have a screenshot of one loss on the way from the Summoning place to the Tower of Bats area.


Tried to capture person bug
#13

I just came back to check it out… This issue is still here? Seriously? In November I couldn’t take a Thrall down the hill on the south side of the river near Hand of the Maker and you still can’t. Tried to take a thrall from Ravager’s Cliff (a cook) to my wheel of pain which is just on the other side of what I assume is a load zone and boom through the world they go. It is consistent and repeatable and was occurring as far back September 29th 2017.

I’d upload an image but apparently I’m too new to link or add an image


#14

before this recent patch i took several thrall from the stygian city to half way across the map. it seems that they had fixed it before but reintroduced it again. hopefully they get on this soon as this is kinda huge part of the game


#15

Must be my fault as this was the day I downloaded the game again for the first time since November. If arrow in the hand comes back we know it was my fault.


#16