Thralls Bow Glitch

Game mode: [Online official 1208]
Type of issue: [Misc]
Server type: [PvP]
Region: [EU]

[Thralls cannot use bows anymore. as soon as I give a thrall a bow, he follows me normally and helps me with the first kill, after the first kill he is just standing like a stature, teleport after me and not interacting with anything. tried removing the bow, give him another weapon but the only thing that seems to get him to work again is waiting for the daily server restart, he then works properly again until I give him a bow. I have tried different thralls, archers and bearers and whatever but bows just don’t seem to work for thralls anymore.]

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Give a thrall a bow.
  2. Make the thrall follow you.
  3. Have the thrall help you kill something with the bow.
  4. Run away from him and witness how he does not follow you properly, teleporting after you instead.
  5. Try have him help you kill something else and watch him do nothing.

Thanks in advance, great game, love it.

1 Like

Hey @Doeden

We’re aware of this issue and we have fixed it internally. Thanks for your feedback :slight_smile:


okay great.
thanks for the reply.
does that mean it will be fixed for me in the next patch? and when is the next patch if so? :slight_smile:

1 Like

We don’t have any estimates yet, I’m afraid. But it should be included in the upcoming patch as far as I’m aware.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.