Thralls disappearing on wheel/oP at point of converting

Game mode: Single-player
Type of issue: Bug
Server type: PvE (Single player)
Region: United Kingdom
Mods?: No
Edition: Steam ; Complete collection bundle £96.00 (Steam Winter Sale)


Bug Description:

Captured NPCs placed on Wheel of Pain are disappearing as soon as they have completed the conversion process on the wheel, (ie: the point at which they have successfully converted into a ‘Thrall’). No sign of them anywhere inside or outside the external world-space.


Installed Mods:

No mods, just single player, no one else on server.


Steps to Reproduce:

Step 1:
Knock out a Tier4 named NPC. In my case, I have tried it with ‘Ana The Reaver’- (ID: Exile_Fighter_4_Wanderer_3), this weekend and also today, with: ‘Ciria The Mad’- (ID: Exile_Fighter_4_Wanderer_10), both of whom spawn in same location, (on map coordinate: i,4). Did not spawn using Admin, I assaulted them directly from game’s spawn location.

Step 2:
Tie up NPC, (level 2 Rawhide bindings used), and drag up the ledge to nearby player base and literally drag the NPC captive onto the wheel of Pain.
(mid-level wheel used in my case, built and placed upon sandstone foundations which I laid before placing the Wheel structure, in an attempt to prevent NPC from ‘falling through floor’, Google search shows this issue seems to be a common issue for about a year now, maybe longer).

Step 3:
Open Wheel of Pain’s UI. Note, that Thrall has automatically interfaced with the Wheel as I had dragged her onto it. (Thrall can now be seen stood in place, pushing the wheel of pain around animation, no need to manually add to inventory). Just add Gruel to Wheel’s inventory, to be used for converting ‘fuel’ and then set process in motion; (activate ‘play’ button in Wheel’s User Interface’).

Step 4:
Wait for Thrall to push the Wheel around for designated time. In my case, I set the admin settings to [0.1] for the ‘Thrall Crafting Time Multiplier’ in crafting section of ‘Server Settings’. This took time down to around 10-20 mins, I made a coffee so can’t be sure of exact time, but it wasn’t long. I returned in time to witness the Thrall NPC vanish before my eyes on the wheel of pain as soon as the ‘conversion’ timer ended.

  • Note that for a Tier 4 NPC, conversion time is 25 hours. Setting time to ‘0.1’ was done for my second attempt, with Ciria. Ana The Reaver, unfortunately for me, took 25 hours to wait for, only to discover her gone.

  • Also note, that after conversion has finished and NPC has allegedly ‘disappeared’, on looking in the Wheel of Pain’s UI, it still shows a ‘shadow’ icon for whomever was recently in there.
    For example, as well as the gruel placed in there, it shows, ‘Ana The Reaver 0’. Same for Ciria, (Note the ‘0’ zero next to name). Not sure what that means.

Tried ghosting underground and flying down through the map’s lower space for quite a distance, (increase movement speed multiplier), but did not see any NPC below the map.

Searched entire house and grounds for NPC, no luck. Totally baffled. Seems as though NPC has vanished into thin air. This bug has at LEAST been present in the game for 13 months, based on search history for this issue. Threads can be submitted as evidence on request, if required.
Screenshots for this issue also available for submission on request.

Hi @Mercd_One and thank you for bringing this to our attention.

We’ve passed this over to the rest of the team for further investigation.

1 Like

This might sound daft - but the way you describe the situation, I’m not sure if I’m understanding you correctly - the animated version of the thrall disappears from the wheel (so it is no longer turning) once the thrall is ‘broken’ - that would be normal behaviour - the wheel stops being turned once the thrall has been ‘broken’ (crafted). So if that’s the disappearance you mention, then that isn’t anything to worry about.

Once the thrall has completed ‘crafting’ - there should be an icon inside the wheel inventory labelled with the thrall’s name (along with the gruel, as you note) - this does seem to be the case from what you describe.
Are you able to transfer this icon into the player inventory (drag and drop with mouse)?
If so - please try placing the icon into an open slot on your hotbar and selecting that slot - you should then find yourself with a ‘placeable’ thrall - once you have placed them down, they will be permanently in the world, and you will be able to move them to other locations or have them follow you etc)

It is the ‘ghost’ icon that confuses me and makes me less certain this is the answer - do you mean actually greyed out - or just that it is an icon labelled with the thrall’s name?

(The 0 after the name is probably just because you are in admin mode - when in admin mode all items appear with their numerical code listed as well)

1 Like

Hi, thanks guys for acknowledgement.

Okay, after some fiddling around and many hours of head scratching, I have realised that indeed, the thrall is still there and has simply become a black, shadowy icon that I can pick up and transfer into my hotbar.

Turns out this is the intended design! For me, this doesn’t look like a converted thrall, ready to interact with. It looks like something that has gone, been deleted and a remnant icon is all that is left.

It is not actually the game being bugged here, this is actually how the thrall becomes created and it looks like a case of just bad visual design over an actual bug. I think there needs to be some kind of “ready” icon or “Converted” notification pop up, or just a tool tip if you hover the cursor over this ominous, dead- looking black icon with your thrall’s name on it.

It would be even better if once the thrall has been converted, they then become tethered to your base somehow, so that you can actually SEE them wandering around your base, ready to become a follower, rather than actually disappear from the worldspace. This is what threw me off, the fact they vanished and then a black icon with no explanation at all available as to what to do next.

Most of the game’s UI crafting is very non-explanatory as well. The amount of times I have to break the 4th wall and break immersion to google how to do something in this game. It could do with some kind of explanation in the UI crafting menus as to what to actually do.

Only today, I have wasted time growing a White Rhino and a White Tiger, only to find out I cannot craft the unique appearance because I’ve already placed them in the world space!!! WHY DOES IT NOT TELL ME BEFOREHAND NOT TO DO THAT??? It can be quite, frustrating, at times…

Thanks for replying, this has been solved as it were, but I think this thread would be VITAL help for anyone else scratching their head as to how to move to the next step once the thrall is converted but why they have disappeared. And it would help to improve the graphics on the icons or animations to help the player understand what has happened.