Thralls In tow disappear

Nope… Thralls are still vanishing at the same spot. Still same issue.

This issue has been present for quite some time. The only way around it, that I know of, is to build wheels of pain in the same cell as the thrall spawning camp. This really needs to be fixed…

Having same Issue on Testlive. Location TeleportPlayer -267400.46875 57796.691406 -3930.612549 …this is the location 3 thralls in a row have gotten stuck…just falls through the map…captured from Septeru City.

In my game any thrall which is dragged along the river next to the cursed city, disappears and the rope then gets stuck in the air… :ro

i made a screenshot but can´t link it :frowning:

I hope this gets fixed soon :confused:

The same place on a multiplayer-Server works, only Singleplayer has that problem.

I play single player non server. I have too this problem. Unconscious thralls disappear.

single player non server as well and same issue
tried 5 times
same issue every single time

Seems like the problem appears evrywhere when you drag the thralls far engouch :confused:

Distance is irrelevant; some thralls vanish when their body reaches certain borders, presumably the ones between chunks.

When testing in New Asagarth, thralls would disappear at the exact same plank on the road leading out of the city. When crossing that plank, some of the NPCs inside would respawn instantly, but not all.
I noticed that I can successfully capture the NPCs that do ‘not’ respawn when crossing that border, but the ones that do respawn vanish every time I reach the border around the city (I tried leaving in different directions).

This bug works on conscious NPCs as well. I rounded up a bunch of NPCs and ran out of the city to a nearby Wheel of Pain. Many of them vanished at the border and a few reach the wheel, where I knocked out the ones I wanted.

Hopefully this helps the devs resolve the issue.


I had this happen and actually unlocked the achievement for getting a thrall, but it did not actually make it into the wheel of pain.

Same here, single player, try drag some dancer from cave, sunk in ground 3 times, not possible drag to wheel of pain. Base est from watchers, south river bank.

Still not fixed! On PC (Single Player) and even put Wheel near camp and they would disappear just outside (very close). I have repeated this step over 8 times now and considering this game fundamentally deals relies on Thralls to upgrade everything, I am thinking of asking for return on my purchase.

BTW: This has happened a three different camps. The Pirate ship used to work about a week ago but now it doesn’t.

I am not much of a forum dweller so I had some problems getting to this point and actualy finding the treat of this toppic instaid of making one myself, anyways,

It anoys me to no end to be in a fight with a named thrall for hours (10 or so differant attempts) and have each and every single roped Thrall vanish at same exact point infront of my Wheel of pain. this is on a Single player ‘server’ on PC btw.

I realise this is not the full released game and so bugs, but I wil ask for a refund if this bug is not fixed asap and even more so uppon full release where bugs should be a non exiting specialy not one’s that are seemingly “known” for as long as this one is.

Honestly in a Game where Thralls are so Center of the game’s core gameplay and to even further your progression there should be NO bugs or glitches AT ALL involving them.


I got this bug as well . hope it gets fixed ASAP.

On the plus side it was fixed at one point so something that was done in the last patch must have caused it. So really they just need to fix what was done… Honestly though I don’t expect them to do much until the 8th… I’m sure they are working on it but don’t expect it fixed until the day one patch.

I just played around with this a little. Tried luring a npc and at exactly the same “border” my roped npc’s vanish so does the active npc.

The Testlive version that went out this morning has this fixed. I’m really happy about that. So when they do the next patch it should be resolved :slight_smile:

1 Like

The bug has re-appeared. Was towing a thrall today, my rope broke, so I had to fix it. Went back to bind the thrall and poof he vanished as I used my rope on him. Kind of annoying, seeing as he was the only Alchemist for miles around. Sigh.

1 Like

This same exact thing is still happening to me too. I’m playing on PS4, whenever I want to repair my bindings or it breaks whilst towing a thrall, the unconscious thrall will despawn as soon as I try to reattach it. No issues with the thrall staying next to me whilst the bindings are reparing…just the ****ing thing disappears whenever I try to start dragging it again. SO FRUSTRATING.