Thralls not combo attacking?`

Hi, logged in today after the update and all of my thralls no matter what weapon they are armed with only do the first light attack. Then they wait and do it again over and over with a long delay in between attacks. They no longer combo attack with any weapon. Is this a known issue and hopefully a fix very soon if this is a known issue.


Yes they need to fix it ASAP considering purges are active, otherwise disable purges until it is.

So I noticed one of my thrall using 2h axe combo with whirlwind. While 2 others I tried do not combo with the exact same weapon. One of those thrall used to combo with it tho. So I tried different weapons on the thrall that didn’t combo with it ever, after someone mentioning that bug existed for quite a while. When using the weapon type the thrall comes with he/she uses combos. Other weapon types seem to bug at some thralls. So I tried 2h Sword/Hammer/Axe, all without combos. But 1h Sword/Hammer/Axe he does use the combo. I know this isn’t as it is supposed to be, but worth looking into, when speaking of Purges. Check what weapon type it combos with and then set on guard with that weapon, at least for now.

This will have to be done if the fix will not come sometime Next week. They said it is fixed internally so i hope a hotfix will come before it comes to purge disabling.

Edit: Pretty please :wink: , can this topic be moved by a Moderator? Or merged with the other threads already existing in regards to thrall behaviour? @Community

1 Like

Hi @Coty,

Thanks for tagging, thread moved to the PC - Updates and Bugs cathegory. :wink:

Regarding the thrall behavior, our team is aware of the issues caused by 2.3 and they trying to address it.
Please keep an eye out to the Patch notes Changelog, for upcoming changes.


thank you for the update Mayra. Hopefully soon but appreciate the quick response here!!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.