Thumb Mouse button can't be rebinded


#1

Hello,

I’m reporting a very annoying bug related to the thumb mouse button.

In deed, the kick action (SecondaryActionV2 in the game file) seems to be binded to the thumb mouse button in addition of the default keybind (LeftControl) wich makes it impossible to rebind.

My goal is to assign the SprintAndDodge action to the thumb mouse button but it seems impossible to do so.

Since those keybinds doesn’t even appear in the game settings, you have to chage them in the game files (that are a mess by the way !), and even by doing so, the kick stays on the thumb mouse button…

So can you please tell the devs about that and try to fix it before the release ?
Because I don’t think I will be the only one being frustrated by those bugs !

PS : I’m french so please excuse me for my poor english…


#2

Did you ever figure this out? I have the same problem! Are you using the Razer Deathadder by chance?


#3

Hello Woody,

Unfortunately no…
The issue is still there and since the devs don’t seem to care about it, I don’t think it will be fix before a long time…
I’m using the Roccat Leadr but the bug is happening with any mouse since that is the generic Thumb mouse button that is involved in this keybind issue.


#4

I am having the same issue using a Logitech G602 mouse on Windows 10 64-bit. Button 05 (thumb button) is bound to kick and there is now way to unbind / re-bind it. Very annoying for those of us who use push-to-talk PTT on that button.


#5

I don’t have issue with my bloody T70 (because I got tired in the past with RMA razor and logitech).
You can try to bind key in ini file.
DefaultInput.ini is in “Steam library\steamapps\common\Conan Exiles\ConanSandbox\Config”

User input.ini is in “Steam library\steamapps\common\Conan Exiles\ConanSandbox\Saved\Config\WindowsNoEditor”.
Find command you want in there and replace value after Key= with ThumbMouseButton2. Also values for modifier in that line should be set to “false” unless you want them.

Defaultinput may reset with updates, and it is advisable to edit it there too. If you ever need to reset binds it will pull binds from there. Defaultinput will have 2 entries for each bind, you need to edit them both.
Also, mouse(de)smoothing can be disabled only from defaultinput, it did not worked for me from input.

Also, some binds in-game can be binded only in primary or secondary, you should try that too


#6

That’s what I did, simply rebind the mouse button but I shouldn’t be forced to do so in order to play…


#7

Which thumb button?

I pressed ThumbMouseButton and ThumbMouseButton2 but they didn’t kick (or do anything) by default. I was able to bind them with no problem. Is there another one?


#8

I think I misunderstood first time. I had issues with rebinding keys in patch when they forced “input” files to update to resolve issues.with binds for opening main menu and other shareable binds.

  1. Try deleting both input and defaultinput.ini files. (deleting only input ini only could work, so try that first because it does not require verification)
  2. (if you deleted defaultinput.ini) Verify files and steam will download defaultinput.ini.
  3. Try to rebind keys and see if they are working.

#9

It’s the button that normally allows you to go on your previous web browser page.
What is your mouse brand and did you do anything special with your keybinds ?


#10

I allready tried that and even uninstalling the game + deleting all related files several times but never worked for me…

Even by changing the files content manualy, they don’t seem to bind into the game.

But I just tried again once more and it miraculously worked !

On the other and, now there is another issue with it… :sweat_smile:

You normally can open a menu and close it using the same use key (for example opening and closing a chest), but when you bind it to the ThumbMousButton, you only can perform the “open” action and are unable to close it by using the “use” key and must press the “esc” key instead…

So I’m finaly back to my old key bindings and mouse profile switching I guess ! :rofl:


#11

I use the Elecom Deft trackball. Yeah I bound the buttons for back and forward on a browser, ThumbMouseButton and ThumbMouseButton2.

I didn’t do anything special, I just bound them the same way as the middle mouse button and any keyboard button.


#12

Having the same issue & it is indeed, EXTREMELY FRUSTRATING.


#13