Unique ID not valid

The information you filled out should now be listed below. :point_down:
Please copy this info and paste it into a new report. Thank you!


PC player here, exact same thing happening


You are not the only one happening on ps4 and pc have not seen any thing from Xbox yet.

1 Like

Yep. This has been going around today it seems.

My wife an i are also having this problem we both played last nite for hes no problem an news on when this is gonna b fixxed or y it’s happening


Xbox is getting it too it seems.


Welcome to the Club was hoping Xbox wasn’t getting slammed with this.


This just happened a few hours ago to my knowledge got home trying to play goofed up wife no problems she brought battle Pass yesterday.

1 Like

Everytime the same after a update

1 Like

PS5 user, same here, played last night no problem. Tried closing and restarting, redownloading the full game and restoring licenses through PSN but nothing has fixed it. Opened a zendesk ticket but RIP to my base probably -_-

1 Like

Me too, PS5, zona UE. Error ID no valid.

Same on PS5. Annoying.

in the bitter wait two hours without being able to play

I didnt buy the pass niether did my wife we cant play u other guys who cant play did u buy the battlepass it may b something accidentally tied to that

The good news is that Mass Effect is the PS+ game this month. Time to dive into another game.

1 Like

Remember tickets will resolve this quicker https://funcom.zendesk.com/hc/en-us/requests/new

1 Like

If by quicker you mean in a couple weeks, then yes, submitting a zendesk ticket will indeed take weeks to get a response.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.