Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

Game mode: [Online | Singleplayer]
Problem: [Crash | Bug | Performance | Misc]

I keep on getting this error, although I exceed the recommended system requirements:

Fatal error: [File:C:\UE4\CSAND\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 805]
Rendering thread exception:
Fatal error: [File:C:\UE4\CSAND\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 181]
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

It appears to be a UE4 issue.

Steps on how to reproduce issue:

  1. Boot the game
  2. Launch any game mode, online or single player
  3. Observe the issue

Hi,
I’ve been getting the exact same error messages and I unistalled the drivers and reinstall different versions. This is happening randomly, and hours can pass without it occurring. Anyone looking into this?

Exact same here. I have done everything that I have in my 20yrs of PC gaming knowledge to resolve the issue with no progress. I opened a ticket a couple days ago, and have yet to get a response…

I ran into this issue as well. Something odd that I found…I use an external USB audio interface for streaming / recording. When running the audio through the USB interface the audio in Conan Exiles would cut off after a few minutes of play and I would get that error. When running the audio through the PC onboard audio I don’t experience any errors. Might just be coincidental but it seems like it is related. Are you guys using external audio interfaces by any chance?

1 Like

Hi there,

So this issue typically means that your graphics card drivers or your operating system need an update. Have you you all updated to the latest on both your graphics card and Windows?

Yep Windows is up to date as well as all drivers

I was getting errors like this when I had my GPU overclocked too high and it got too hot. I backed off the voltage and speed a bit and went away.

Hi, just like TrouserMinow, my drivers (NVIDIA 397.64 )are up to date and I am using the last Windows 10 update 1083 April. I am kind of stumped by this.

UPDATE

This is happening only on settings above medium and low shadows.
The issue seems to be linked to either higher texture resolution, rendering issue or anisotropic filter.

Can any of you guys confirm this is also working for you? At least we can kind of narrow it down for the devs.

I didn’t change any settings, last time i have played was 2 weeks before release and now i have Line: 805 problem

I verified files and showed 180 missing, no idea how… but steam redownloaded them and now everything works great

This type of issue sounds familiar, OP, can you do me a solid and get me a copy of dxdiag and crashlog from conan?

Upload both crash log and dxdiag to https://pastebin.com/ (as separate uploads) and share it here. My theory is that you have two graphics cards in the computer, a dedicated and integrated. It is most common for laptops with dual video cards, but can also occur in desktop machines. For some reason CE ends up using the integrated graphics card. The integrated is not powerful enough and it usually end up with an error message where D3D device is lost.
I’ve never dealt with it myself, but you can google for ways to enforce game to use dedicated graphics card.

Guys,

I’m stuck at work on a Bank Holiday…

Can anyone experiencing this exact issue (see summary headline) do what Zing advised above? Otherwise that’ll have to wait.

did you verify files?

Yes, I’ve reinstalled Windows 10 and downloaded the game from scratch.

Hey Zing, here’s the stuff you’ve asked for:

https://pastebin.com/DqB4zK5K

https://pastebin.com/EhZfmQSG

Having the same issue.

Zing Confirmed, I am using a desktop with both onboard an dedicated graphics. I am also running 2 monitors, 1 plugged into the onboard and the other into the card. My game crashes at the same point every time, right after the intro plays, before I have a chance to open the settings or make any selection.

I followed directions I found on stackexchange to force the game to use of my GTX 1070 but the results are the same.

Edit: As a test I shut down the system and removed the screen using the onboard video, then restarted. Got the same error at the same point.

Do you have a link to this Stackexchange post?

Charcola this is what I found, as I said, it did not work for me, hoping it works for you.

It won’t let me past a link so I just copy/pasted the text.

I have a similar computer set up, and here is how I make it work:

  1. Go to the NVIDIA Control Panel by right clicking on your desk top and clicking on “NVIDIA Control Panel”.

  2. In the default screen that pops up (it should be “manage 3D settings”, and the “Program Settings” tab should be automatically selected), under “1. Select a program to customize:” hit the “Add” button.

  3. From here, navigate to the folder where your steam games are located. For me, it is C:\Program Files (x86)\Steam\steamapps\common.

  4. Select the folder for the game you want to use your NVIDIA card for, and find the .exe for that game (it’s usually right in the main game folder). Select it and hit open.

  5. Then, under “2. Select the preferred graphics processor for this program:” open the drop-down menu and select “High-performance NVIDIA processor”.

  6. Finally, hit apply in the far bottom right corner, and you should be good to go!

When you start the game from Steam, the .exe will be opened, which will now run with your NVIDIA card by default rather than your integrated card. I’ve noticed that most older games, when started, will use the integrated card by default. The method described above can be used for any .exe file, not just games in your steam library!

I have a screenshot of the error I am getting but as with so many other things I cannot do as a new user on the forums, I cannot upload the image, I also cannot provide a link to it in my photobucket :frowning:

Oh, thanks for the info.

Although I have just one GPU so that’s not working for me.