'Warhammer of the Legion' weapon disappears from thrall's inventory

,

Game mode: Online private (no mods)
Type of issue: Bug
Server type: PvE
Region: EU


The discovered and crafted epic ‘Warhammer of the Legion’ hammer disappears when it gets into a thrall’s inventory.
The first time I crafted the weapon and gave it to a thrall it was working fine for ~2 hours. The I died and the thrall ‘teleported’ back home. And I realized that he had no weapon. His inventory was empty, he had his armor tho.
The event log shows no information about the weapon. only that I picked them up from the crafting station.


steps (v1):

  1. Discover the ‘Warhammer of the Legion’ weapon via the Delving Bench using Hardened Steel Hammer.
  2. Craft the epic version of the weapon in a normal blacksmith crafting station.(I had a simple ‘Blackhand Blacksmith I’ in the crafting station.)
  3. Add ‘Spiked Weapon Fitting’ to the crafted weapon.
  4. Give the weapon to a thrall - drag&drop the weapon into the last inventory slot (but I guess the slot does not matter).

steps (v2):
Repeat step 1-3 from the previous section.
4a. Give the weapon to a thrall - drag&drop it onto its ‘body’, so the thrall will use it in its hand.
4b. Give the weapon to a thrall - drag&drop it into the main hand slot, so the thrall will use it in its hand.
5. Drag&drop the weapon from the thrall’s hand into the thrall’s inventory.

I tested this with a normal T3 fighter, and with a (500+ chaos) summoned T3 fighter. Both were lvl20 by that time.
Tested the same steps with the discovered, epic ‘Headache’ hammer. It is working as expected, this weapon does not disappear.

Hey @Felreen

Welcome to our community and thanks for your feedback. It’s been relayed to our team so they can look into it.

1 Like

Hey @Felreen

Welcome to our community and thanks for your feedback. It’s been relayed to our team so they can look into it.

1 Like