Water around Telith Lake

Game mode: Online private
Type of issue: Possible Bug
Server type: PVE
Region: US


Is anyone else seeing large checkerboard appearance and lack of water texture detail in the water areas on/around Telith Lake, including the rivers flowing from it to the waterfalls?

It’s like the close-up texturing doesn’t come in correctly or something. Below the waterfalls, the water looks perfectly normal. But the lake and rivers directly above are weird.

Water at the aqueduct areas seems to have a lesser issue, in that you see the checkerboarding from a distance, but up-close it textures correctly and looks normal.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Enter game.
  2. Go to Telith Lake.
  3. Walk/ride/fly around and observe lake water textures.
  4. Compare to aqueduct lake water textures and below-waterfall water textures.

Can you post your modlist, if you have one. I’m having the same issue.

1 Like

I have checked in my game and the water looks normal around Telith’s Island and the other places shown in Queen’s post so probably a mod related issue.

1 Like

Ya, same as Narelle. I checked a bit ago when it was posted on the mod discord.

Clearly a mod issue.

1 Like

Queen,

Modlist is as follows:
Pippi
ThrallRadius
Valhalla Archery
BouncyCastle
Martial Combat
Tier 4 Thralls - Mild Increased Spawn
Stacksize Plus
Barbarian Barber
Akuba’s Salon
RA: Character Customisation
Kerozards Paragon Leveling - Reloaded
Age of Calamitous
Kerozards Paragon Leveling - Smooth Leveling Add-on
Glass Constructions
Cathedrals
Classical Architecture
Lemurian Architect
Immersive Armor
Fashionist
Emberlight
Javelin Improved
ExilesExtreme
Dude’s Delightful Decorations
Dark Desires
Improved Quality of Life
Pythagoras
Pythagoras Support Beams
LBPR - Additional Features
LBPR: Fish and Shell Trap Bug Fix
Less Building Placement Restrictions
Darkwoods
Riverboats
Pickup+
ModControlPanel
Expanded Map - Curse Wall Removal

Of those, water blocks are from… Emberlight? And maybe Riverboats may affect water textures. Not sure, though. Waiting for more mod updates to roll in, will see if they resolve remaining wonkiness.

I do not have emberlight, no riverboats. The only thing that comes close to map change is EEWA, but you don’t have that.
20210424214040_1

So the mods in common are:
pippi
kerozards
dudes
pythagoras
fashionist
lbpr
mod control panel
RA
barbarian barber
immersive armor

of those, i think only dude’s or maybe LBPR could even possibly be relevant.
RA has updates pending;
there’s a few others on my list pending as well, but. :man_shrugging:

Waiting Is.
I’ll update this thread if I see a mod update that fixes it.

Regards,
Eudas

My wife went through our modlist, adding 1 at a time, and testing at telith lake for repro.
She found that the following mod activated the checkerboard waters at Telith:

Expanded Map - Curse Wall Removal
Mod ID#2436403535

She removed all mods, retaining only that one, and it also repro’d.
The waters at Xullan were also affected.

3 Likes

I can comfirm that I have the same problem with water, looks the same like yours.
im playing on official server on PC, the water problem since the new update.
its like you cant see threw

Issue is with Age of Calamitous Mod. It should be resolved now after their recent update.

We replaced

with

And now the in-game water looks correct at Telith Lake, Xullan, and the aqueduct.

The new aoc compat cursewall mod says “edited to be compatible with AoC’s lighting and post processing”, so perhaps those of you not using cursewall removal or aoc may look at other mods that make changes to lighting/postprocessing.

May this information be useful for you all as well.

1 Like

I do not have those mods, I’ve never had AoC on server before.
Same with the Cursed Wall mod, never had it.
I’m still stuck with this.

We don’t know what causes it, we don’t know how it’s fixed by others…
Another patch, another monthly cancer pill.
Its great, a giant checkered texture sea.

@AstroPony So, you are on “Official” yet still having the issue… Need expert opinion on this.

I would try start some tests on a singleplayer game. New game.
Install one mod ad once, see if one will trigger it. If there is no result, do pack of mods, then run them, see in what pack the bug happens. May take some time depending you modlist, but hard to figure out the other way.

word is that any map mod may cause those issues whether author actually edited anything or not

Load them into a test save on single player, and remove mods one or a few at a time until you can isolate it.

after the last hotfix, the water is “back” to normal for me, its not “redish” anymore.
my problem is my game settings, as im playing on low on all settings.
this is what I’m seeing at low settings:


same with medium settings.
when i put on high settings, i can see the water as normal.
this is what i see on high settings:

I’m not sure when they changed it becouse I’m playing on low settings from my day 1 since 2 years ago.
im not sure what is your problem becouse you running on mods, I’m playing on official server so no mods here.

I’ve done that, at best a random flicker happens on one of my dungeon mods, where I’ve never touched this area before. I’ve been to content folder, there is no alteration to this area, intentional and unintentional.

The mod hasn’t been updated since 2.3. After 2.4 it’s broken (the lake). I rebuilt the mod, no change. They have messed with water textures and its somehow interfering, but there are a lot of people suffering from this without any answer to what was actually changed on that lake that makes it so.

We know that red oasis was infact a vanilla game problem, and its fixed by vanilla patches. And again, “I do not know” what causes it, because even if we know the allegedly culprit mod, we don’t know what causes it in the mod. The area is “untouched”. The water texture is “default”, it’s properly shown as it should be on devkit, but not on game server.

See it also the same way, also with ultra settings here:

For my taste bit to transparent, loved more the more blue look. Still we can see to the ground.


This issue should be fixed with 2.4.2. See the patch notes here:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.