Water Broken(Massive Texture Issue)

Game mode: [(Online private)]
Type of issue: [Bug]
Server type: [PvE/PvP/RP]
Region: [America]


[Textures Are REALLY Broken]


Pictures say it all;

1 Like

Hey @kritacul

Thank you for reporting this issue. Since you’re playing with mods, are you able to replicate this issue with mods disabled?

Adding 2 cts ontopic.
PC -Vanilla.
Official pve-c.

Water is not transparant anymore from outside the water.
From (swim/dive) inside water you can see, but low light.

(any)Graphics settings do not solve.

(?)Sub related:
When mounted in water.
Horse can’t get out of the water anymore,(rubberbands)
Need to unmount to get ashore.

I’ve noticed that too. The water’s always been clear and I’ve always been able to see the plants, rocks and other things around them. Now I see nothing and it just looks like large puddles of odd liquid. Also, my followers have started having that rubberband thing happen with them in the water as well. I haven’t given much thought about it though. The way the water looks now doesn’t harm my game in any way, but it looks kinda crappy compared to the nice clear water that actually looks like water.

1 Like

Hey @Ignasis ,

I’m the owner of the Vehement Server… We are experience this same issue.

We have determined that this texture error occurs near the Bridge of the Betrayer and Telith’s Island on the Exiled Lands. We are receiving this error in our Error Log in rapid succession…

To answer your question, It has happened in Single Player as well. Though, I am using Mods in both instances.

I tried it without Mods and the water returns. Trying to figure out if its a specific mod causing the issue…

Edit: It’s “Age of Calamitous” base mod. Loaded in with just that Mod and the texture broke. I’ll let them know in their Discord!

Blockquote[2021.04.24-06.10.47:491][ 91]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.48:494][121]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.49:493][151]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.50:564][183]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.51:570][213]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.52:573][243]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.53:671][276]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.54:676][306]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.55:678][336]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.56:777][368]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.57:781][398]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.58:783][428]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!
[2021.04.24-06.10.59:785][458]LogStreamableManager:Error: RequestAsyncLoad called with empty or only null assets!

2 Likes

Dang, I thought we were getting Strategic Water but it’s just a mod mismatch.

1 Like

Exactly, at each launch this messages are repeated again and again.
There tons of these lines.

Tested it with different new games, no mods at all. Same on Exiled Lands and Siptah.

That’s realy a major issue yet !

Again, i have same errors without mods, not to speak of Age of Calamitous. Even in vanilla game you get same errors in log.

1 Like

I’ve the same bug, I do not have AoC, never installed it before on the server.
At the bottom is my modlist. Also we have this weird mexico filter on desert areas, with serious brown orange tint on everything. Oasis lake is like muddy or something…

20210424214040_1

1 Like

I’m having the same issues sadly. I can’t post pictures yet because I am new to the forums, but it’s the same as above.

Can you post your modlist please.


Some or all issues mentioned should be fixed with 2.4.2. See the patch notes below:

Age of Calamitous was the culprit last time. After an update they did, it fixed. Though, if its just base game this time around, not sure.

After the base game fix, there were still people who do not have AoC having issues. It’s an issue with the Granite plugin which handles the textures from what I know and has happened with other textures in the past.
These people should test without mods if the issue persists and if it’s fixed for all locations.

It would also be good to know if textures completely missing on water -and other things- with and without mods is still an issue for those people.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.