Waterskin disappearing repeatedly


#1

Game mode: (Single-player)
Type of issue: (Bug)
Region: (Czech Republic)


I always try to carry on me a full waterskin, which has proven useful countless times. However, it has happened to me at least 3 times now that the waterskin simply disappeared from my inventory sometime during the time I was playing (I crafted it, filled it, and sometime within 40 minutes from then, it disappeared without me logging off). I tried re-logging/rebooting the server, as I play singleplayer, but to no effect. I can´t rule out the possibility that items are disappearing for me in general, but I doubt that since I never noticed anything else disappear.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Play singleplayer (not sure if this is related or not)
  2. Craft a waterskin (not sure if you have to craft it or the issue can occur even after getting it another way)
  3. Place it in your inventory outside your hotbar after filling it
  4. Wait for it to disappear as you play

#2

Heya! Thanks for the details. Yes, knowing it’s in singleplayer definitely helps! :smiley:
Firstly, do you have any mods?
Secondly, do you only notice the waterskin vanishing when placed in your inventory? Has it ever disappeared when it was in your hotbar? Sorry that’s happening for you! :C


#3

Hi, no, I am not running any mods, but that is irrelevant actually, I just figured it out and it was just my stupidity :smiley: I didn´t know that space while in inventory discards the first item in the inventory, and that is where I would always keep my waterskin… you can delete this topic :slight_smile:


#4

I was actually about to ask you to check this. For whatever reason, I too have had moments where I’ve brushed space and have ended up dropping the waterskin (and other items) on the ground. Careful with your clicks!


#5

Ahh! No problem! I’m happy to hear it’s sorted out. :smiley: Thanks a lot for the update! If it’s okay with you, I won’t delete this just in case other people have the same issue and need a solution.