Weapon & Shield Display Racks not showing items (Singleplayer)


#1

After placing a weapon or shield rack on a wall and putting a weapon or shield into the display inventory, nothing shows up. I’ve tried multiple types of weapons/shields. I also been exiting the inventory of the display rack, to see if that will update the item model, but it does not. Please fix, thanks :slight_smile:

Btw thanks for sticking with it to full release! Conan Exiles is one of my favorite games.


Game mode: Singleplayer


Repro steps:

  1. Place either Weapon Display Rack or Shield Display Rack.
  2. Add item (weapon or shield) into display rack inventory, then exit the inventory while item is in rack container.
  3. No visual change to any Display Rack, stays empty.

#2

I have this same issue, but I have noticed if I leave the weapons in the rack, and exit the game and return, the weapons do appear and remain visible.


#3

sometimes they will also appear if you leave the area for a bit and come back letting the area re-load


#4

It happens when you place the rack. For it to show weapons or a shield you have to exit the game and come back. I am not sure what the equivalent in online play would be, whether logging off is enough or if the server needs a restart. I tried moving far to another cell and come back, but the display rack wouldn’t update.

After a restart, if you don’t move the rack itself, you can change the items on display and it will update asap.


#5

This is still a problem.


#6