3.0 in TestLive is not starting


After TestLive was done downloading and installed, it gives me a Steam error and closes before the launcher even comes up. Tried with both the standalone client as well as the beta branch. It has been a long time since I tried TestLive, am I doing something wrong on my end or is the build failing to load?


EDIT: I re-verified all the files (both in the standalone client as well as the beta branch) I re-downloaded Steam re-distributables and now it gives me a message that says Steam can’t sync, and asks if I want to play anyway. I chose to play anyway but the same error message (app running) keeps coming up.


Pffft…I just restarted Steam, and the launcher comes up fine. Problem solved! :wink:


Mine got red text saying “corrupted update files” with a curved retry arrow. I clicked it and it now allows me to start it. I get this crazy and unintuitive screen:

Which I waited 20 minutes for to go away!!!

Finally I pressed Back and was presented with the usual “Play Online”, “Single Player” and etc.

Going single player it loaded up and allowed me to create a character on Siptah.

1 Like

I am having the same issues as above. Tried restarting and all that, just seems to load forever to no avail.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.