A Time to Every Purpose crafting area


I am now doing the A Time to Every Purpose mission. When trying to assemble the 1st set of items nothing happens. Moreover, I only have 4 squares by 4 in the crafting area instead of 5 by 5.

PS: I can’t paste print screens.

Thanks in advance for your help,

1 Like

For this mission i advise the following:
Break down all materials and separate them in your “Mission items” inventory first.
You can make this as big or as small as you like for the process by dragging the bottom right corner to your desired size

Once all items are separated in there, place them in to the crafting window to make the Ancile components.

I have found doing it this way works every time.

The Pattern for The Ancile doesn’t stretch to beyond 4x4 anyway so the crafting window size is enough.
(despite older guides showing a bigger crafting window - the crafting patterns are however correct)

Hope this helps.

4x4 is normal for the SWL crafting window. TSW had a 5x4 grid. You may actually be on to something here. This definitely warrants more testing.

People have been complaining about the crafting in this mission being buggy since SWL was in beta. I feel like if they were able to diagnose and easily fix the problem they would have done so by now.

I know. But the grid size change is something I’m not sure anyone’s ever pointed out before.

I don’t think the grid size is what causes the problem tho, because the problem was also present in TSW.


Expand for detailed crafting with pictures (SPOILERS)

Expand “Mission items”
Break down items
Separate Items in Mission Items inventory
Replicate this image in the crafting window

Don’t separate them inside the crafting window
Same for the next component

I just tried something on two of my toons.

First attempt:
I did as I mentioned - separated outside the crafting window (In mission items first)
Then placed each bit in - one by one to the crafting window.

However, i didn’t craft the item.

Instead I wanted to see if it would craft also from within the crafting window. Placing all the chunks inside it and separating it inside the crafting window. It did, so i had component 1. (Umbo)

When i then tried to do the next component (Ancile Replica) with all the parts separated outside first - it would not craft.
Yet it would craft the Ancile Replica if I followed through with how i did the first part.

Second Attempt:
Crafted as normal both parts separated in mission items first - no problems.

Perhaps worth looking into - but i think there could be two ways to craft and they both must be done the same way as each other, or the component does not work. Which might result in people being confused as to how its meant to be done.

It could be absolutely nothing at all like that and is entirely RNG on a bug or not.
Who knows eh.

Was it? I’ve never heard of anyone complaining about that before the relaunch.

I certainly encountered it many times in TSW. I ran the mission often enough to be frustrated with it that’s for sure. When encountering it in SWL I thought “They didn’t even fix this”.

1 Like

Funny. I’ve run through that mission dozens of times in TSW as well as SWL and never encountered that bug until last night when I actively tried to get it to fail by messing around with different crafting windows. :woman_shrugging:

1 Like

Its a weird one lol So i dunno what causes it. I just know i’m all too familiar with it.

Going to necro this thread in case anyone else is still having this prob, just spent the last half hour trying to assemble the ancile; nothing was working.

Decided to /reloadui and voila. Worked perfectly. Separated the mats inside the crafting window.

Hope it helps somebody!

(Also, I had this problem in TSW too.)


Was having a terrible time with this quest. Tried all other fixes on reddit and here and nothing worked.

I noticed that the table would show my completed pieces if I had my upgrade window showing. On a whim I opened my inventory using I instead of Y ( to open inventory and the upgrade windows at the same time) and it allowed me to craft the ancile.

If someone comes across this issue in the future make sure the Upgrade window is not open when trying to use the Assembly table.