Crafting Bug during Quests

Basically, I cannot use the Crafting interface. The “Assemble”-Button just won’t highlight and cannot be pressed, leaving me unable to complete quests involving assembly of quest items.

I encountered this issue during several quests:

  • A time for every purpose Tier 2: see forum post (a-time-to-every-purpose-crafting-issues/3427)
    Assembly of the Ancile worked for me after stacking quest items in my inv and trying different workstations.
  • Appeasing the flame Tier 4: Assembly of the 4 rings didn’t work at any brazier, in no combination. Pausing and restarting the quest only led to getting stuck one step earlier, being unable to get the fire ring from the dead Rakshaza because the (unique) quest item was already in my inv. I was only able to advance when a GM gave me the combined ring.
  • Fight for your rites Tier 2: Can’t assemble the tablet fragments in the brazier. Same problem as reported on reddit 3 years ago (6n7yst/fight_for_your_rites_still_bugged), still unresolved.
    Restarting the quest creates the same problem as above, unable to take the 2nd fragment from the skeleton until GM deleted the unique quest item from my inv. The quest involves additional assemblies at tier 3 and 4 … yay -.-

This is where I’m stuck now. GM told me to ask on discord (where people told me to /petition) or forums.

So is there ANY workaround? What can I do exept bothering GMs again on every crafting step to do it for me?

1 Like

I suspect you’re stuck with shouting for a GM, as it will be a real challenge for them to resolve as it is not consistently present.

The issue occurred for a friend on A Time For Every Purpose (frustration put her off repeating the quest ever) but I tried to reproduce it on different characters and PCs and couldn’t make it happen. I played through all of the quests you note during the anniversary with no issues.

Maybe one thing they could consider if they look at it is removing the unique quest items from a player’s inventroy when the quest is restarted; not sure how easy that would be to manage…

I can’t remember if it’s a sharable mission, but i wonder if that might be a way to work around it. If a team member could interact with the items and possibly do the crafting?
I haven’t done missions much in a group, so i don’t have experience if it could work or not, just an idea.

Hi, thanks for the answers …

I tried sharing the quest, but even though the other player in my group could assemble the items, that didn’t advance my own quest. In addition to that, my kind helper also got stuck at the next tier, unable to pick up the unique quest item after pausing and restarting the quest :frowning:

So yeah, I’m left with petitioning.

Consistent or not, I wish they would abandon the crafting interface altogether and just have you click the items. Anyway, pausing a quest should not leave you with items you’re not supposed to have.