Accidentally built a block underground. Can I dismantle it?

Letting it decay is not an option, because it’s connected to my base.
And I definitely don’t want to let it exist there, because it’s creating snapping points when I try to build near it.

you canto do nothing. It is the same with underwater blocks. Funcom quality after 2 years of development

1 Like

I’ve had that happen to me before. It created snapping points that were completely wrong for what I was trying to do and I couldn’t dismantle it because it was entirely underground, so I couldn’t even see a little corner or anything that I could target.

Ultimately I ended up going into the admin panel and flying down below the ground to get at it.

3 Likes

I just tried to get rid of it using demon fire orbs and explosive jars. They don’t do any damage to any of my building elements. Probably because I’m on an official PvE server.
Are there any monsters that can damage player structures, other than purge monsters? Unfortunately, purge is still broken on our server (#1090).

Hi tim I’ve been testing this out with PVE settings and I might have a solution. FYI despite my being a Set follower, on PVP Mitra is the dude you use for killing any “low-cast” stones. His stomp does a lot of sponge-soil penetration.

This is tricky and I hope it makes sense. You’re going to be placing a block on top of the mis-cast one. Pretend you have cast a block at 45 degrees to your setup, subterranean. Can you peel back any surface blocks that would impede your progress? If you can, you should try this:

  1. Point your mouse well below where you think you are casting your block.
  2. Ease your mouse up until it juuuust registers “placeable.”
  3. Practice this motion so that you can easily repeat it. Practice it in reverse.
    PLACEMENT
  4. Barely move your mouse upward until you can place your block. Place it without reorienting your mouse.
    DELETION
  5. Delete your sacrifice blok, then immediately move your mouse down as you’ve practiced.
  6. If you are super-fast you will 4/5 times catch the mis-cast block for deletion.

Please note this is a sample test on a well-running server. The key is to be able to “orient a ghost deletion” with swiftness. Good luck!

3 Likes

Alternatively, build a ring around it and call it sacred ground. Or, you know, throw your garbage in there. Or both. :grin:

3 Likes

Place a barrel (or any other placeable) on top of underground foundation, that way u prevent snaping (i think)

Well, I tried eveything, without success.
I guess I’ll have to live with it.

Tim, I apologize for wasting your time if this does not work, but I consider myself a competent builder and have run into all manner of frustrations. I think this should help. Is it possible to use ‘fence foundations’ on the good foundation (the foundation that is placed where it is supposed to be) and another adjacent to it (overlapping where the bad foundation is)?

Forgive me being repetitive for a moment but I want to be thorough:

[ Foundation Above Ground ] … [ Empty Space Above Ground ]
[ Empty Space Under Ground ] [ Bad Foundation Under Ground ]

Sometimes Fence Foundations ignore the snapping and will go through other pieces, which would be extremely beneficial in your circumstance. Please try to put a ‘Fence Foundation’ on the Foundation Above Ground, and then connect another ‘Fence Foundation’ to the one you just placed, in the Empty Space above the Bad Foundation Under Ground.

If this works, you will either a.) potentially be able to snap/override a Foundation to the ‘Fence Foundation’ (provided the bad foundation under ground isn’t interfering) or b.) be able to use ‘Fence Foundations’ to ignore the bad foundation snapping.

Sorry if this isn’t clear, it’s tougher than I thought it would be to articulate. Please let me know if you achieve favorable results.

2 Likes

Thank you, SteveKeepsDying, for your very thorough instructions.
However, my problem goes beyond mere snapping. There is another underground block that was placed during a scramble of foundation spamming to claim territory between neighbours. The territorial disputes have since been resolved, and most foundations have been dismantled by both sides… except one that happens to sit inside a natural rock next to a big iron spawn (9 nodes, I think). That block is preventing the iron from spawning, and even though we all would like the iron to be freely accessible to everyone on the server, it is now ruined for everyone because i can’t figure out how to demolish that accursed block.

… And that’s how the Exiled arms reduction started.

Sorry, couldn’t resist.

As to your issue, Just to confirm, you can’t, say… pull your base back from it slightly and allow it to decay, right? As far as I’m aware, it should only share your full timer if it’s physically connected to your base. Otherwise it’d only have a partial and you could… potentially wait it out. Given it’s underground, iirc it should poof on its own.

Sometimes things that are not directly connected but just close will still share a timer. I don’t know exactly what the limits are - and it actually seems to vary, sometimes - but it’s very possible that he’d need to pull back significantly for the rogue foundation to go poof.

I have a wedge foundation placed inside the terrain (by accident) near my main base, and it’s led to all sorts of annoyance - but short of dismantling most of my base, there’s nothing I can do about it. In the end I managed to “build around it” by using walls and ceilings instead of foundations - but that’s not always going to be possible, and it disturbs my eye whenever I look at it (since walls and foundation block sides look different).

I know those feels… My eye twitches sometimes when I’ve seen parts of my buildings that just… don’t look right but there’s no alternative.

Since its PvE why dont you use the explosives bug to break it?

“Since its PvE why dont you use the explosives bug to break it?”

Tell me more about this explosives bug. I already tried demon fire orbs and explosive jars, but they didn’t do any damage to the control blocks around it. Is there a particular procedure?

1 Like

@Jetlag Your post got my hopes up (I have a similar problem), but I suspect this bug has been fixed. I just suicided twice atop 2 mines and 4 jars, and not a single block was damaged, let alone the one I’d hoped to destroy. :frowning:

That wouldn’t work. The block shares the same timer with my base because it used to be part of a contiguous structure. Things that were built contiguously are always considered to be one single structure by the system, and they will always share the same timer, no matter how far apart they are, and how much time has passed since you deomlished the connecting parts, and how much time has passed since you last visited it.

1 Like

I am, of course, acutely aware of the irony of the situation. :sweat:

Bumping to prevent auto locking.

Still hoping that someone will know a solution.