After People of the Dragon patch 2 very bad new bugs. ITEMS DISAPPEAR = GAME BROKEN

Game mode: singleplayer
Type of issue: Bug
Server type: singleplayer game
Region: singleplayer game
Mods?: No, never installed mods, full vanilla all the way since day 1

Bug Description:

  1. since patch, made a new saddler’s workstation. placed thrall. put some saddles in there. went away from the base, came back, they disappeared. rebooted the game, they reappeared. rebooted the game again, they disappeared. rebooted again, they didn’t come back. tried picking up the workbench and putting it down again, to no avail, thrall and saddles all gone.

  2. since patch, ALL saddles have changed color to an ugly, bland lavender color. tried taking off the saddle, putting other saddles, rebooting, no change. this was the entire reason i made the saddler’s bench in bug 1 and discovered that bug.


Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. can’t reproduce the reappearance of the items that disappeared from the saddler’s bench since that first time it happened (and i regret not taking the items and thrall out, but wanted to test it, and also wasn’t sure i wasn’t going crazy so…). items and thrall disappeared, reappeared, then disappeared again, seemingly for good.

I’m going to stop playing this game until this is addressed, because this is very game-breaking, since the entire basis of this game is collecting and using the workbenches.

1 Like

Same problem here with saddles color, all blank.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.