Annoying Stutter/Framedrop in Conan Exiles Steam latest version (exiled lands)

Greetings!

Game mode: Single-player
Type of issue: Performance
Server type: -
Region: EU
Mods?: No
Edition: Steam


Bug Description:

I recently did a fresh install of CE to play the Age of Calamitous Mod in SP. But with or without the mod installed I encounter stutter with framedrops while moving (~15 FPS wihout mod). I can reproduce the stutter, when I move out of Shelter of a big rock, wait and move back into.


Installed Mods:

None. I would like to use Age of Calamitous…


Steps to Reproduce:

Start the game.
Moving in regions with more than sand and a few stones.


Hardware:

HP Omen 17 G-Sync Gaming Notebook
Intel Core i7-10750H
NVIDIA GeForce RTX 2070 Super (8GB dedicated VRAM) with latest driver
16GB RAM
1TB SSD
CPU-usage while playing is ~30-40%, GPU is ~95%, VRAM 3,6GB of 8GB used. 6GB RAM free


Additional Information:

With more objects to render it gets worse, so using the mentioned mod is not possible. But even without it is annoying. I tried everything from lowering the video settings to messing around with the nvidia control panel - no effect.
After that I tried the following steam launch options:

-USEALLAVAILABLECORES
-USEALLAVAILABLECORES -lowmemory -high
-norhithread
-NOTEXTURESTREAMING
-NoVerifyGC

…No effect…

The last try was editing the engine.ini. For example:

[SystemSettings]
r.bForceCPUAccessToGPUSkinVerts=1

…No effect…

or

[/script/engine.garbagecollectionsettings]
gc.MaxObjectsNotConsideredByGC=476499
gc.SizeOfPermanentObjectPool=100378488

…No effect…

This

[/script/engine.garbagecollectionsettings]
gc.MaxObjectsInGame=7400000
gc.MaxObjectsNotConsideredByGC=52000
gc.SizeOfPermanentObjectPool=15000000

let the game crash on loading.

But with this one here

gc.BlueprintClusteringEnabled=True

I got framedrops from 30-40 FPS instead of the “normal” 15!


It is more than frustrating. I can run anything I want on my rig without problems and smooth like butter.

Help would be nice!

Best regards,

CptKLab

1 Like

here to confirm… ish

for me its the other way around. im running on inferior hardware but its my cpu thats at 95% usage, while my gtx 1060 sits at a meager 40%. at first i thought its just because im running on a hella old cpu(i still have an i5 4460, the recommended cpu for the game is an i7 3770k) but seeing as the game used to run just fine, and its using much more of ur gpu than it is mine despite yours being way better… now i have to wonder

thank god i thought my PC was just bad but turns out its just the game’s steam optimization (at least thats what im getting from this?)

I got a mid tier build that worked on this game a while back but now seems to tank whenever i fight or move to fast or get hit. Any other game is fine and as stated it worked like 2 years prior to my posting today.

Is there a fix or do i just need to buy beefy PC parts cos games are only meant for the rich?

I guess, it has to do with the unreal engine 4 and its optimization possibilities for the game. Perhaps there is more to find out about texture streaming or the garbage collector, but I am not a developer…

I found the hints for all the screws in the engine.ini in a post for another UE4-Game. There is a lot more you can do concerning quality settings, for example more detailed distance qualtiy settings or disabling shadows.

i mean ue4 has a decent track record of running well. its no id tech but it can be really optimized

look i just wanna be able to play without getting my butt taken to brown town cos the game wants to off itself due to my character jumping. Again this worked a while back so wtf happened?

for me it ran great just like 4-5 months ago and now im having bad cpu usage. in my case its most likely just my cpu showing its age but since its happening to you…

well i imagine you should be fine just verifying the integrity of the files. if not, try lowering some video settings. and if that doesnt work, time to reinstall the game and hope for the best

oh right also check to make sure ur geforce drivers are up to date

i hear you. it sounds like it could be memory leak introduced in a recent patch. a temporary workaround might be to lower video settings

done about all that n still nothing. Devs need to fix this. Even on low end laptop mode it still did that

really? damn
well all thats left to do now is wait sadly

man life used to be so cool now its just endless disappointment :confused:

its really a shame these things happen because this is an otherwise really solid game with an interesting and diverse world

I wonder if there is a difference between the steam and the microsoft store version of the game…
not that I think this would be the solution…

Glad I saw this thread. Been having the same issues even though I have set all my graphic settings as low as they can go. If I get anywhere near a structure area that needs a lot of rendering, it’s stutter, stutter, lag, lag, lag, stutter. Was starting to think it was my pc, but maybe not

whats ur cpu and gpu?

CPU: Intel Core i7-3820 CPU @ 3.60GHz
GPU: NVIDIA GeForce RTX 2060

dude your cpu is a huge bottleneck

What do ya mean? I’m not very computer literate

EDIT: went and educated myself lol. Yeah, some guy in FL built it for my wife last year. If PC crap wasn’t so damned expensive, I’d upgrade. Unfortunately I have other financial priorities right now. Oh well, at least the lag/stutter isn’t game breaking, just annoying :blush:

The used hardware may be the problem in some cases. Years ago I was glad when I could play Battlefield 2 with 45 FPS and 1280x1024.

And not only did I play CE with the specs mentioned in my first post, I used to play it with an i7 8th Gen and an GTX 1660 TI. And I had exactly the same stutter. Lowering settings is not the solution. Even if I limit the frames to 60 I get the same framedrops as with 120.

In my case here the hardware isn’t the problem. It has to do with the amount of objects to render. As I mentioned above, in the desert with only some stones around there is no lag, no stutter. And with an UE4-Setting I can make it worse, so there must be a way to make it better.

So I also tried the microsoft store version of the game, and I get stutters. To make it worse, the game was installed in the wrong language (english when it should be german), it “forgets” settings like FOV and mods cannot be activated. Just want to throw something out of the window…