Arcane Staff not working after learning 10+ additional spells

learned Sorcery, got first book and arcane staff, first two spells working as intended, used workbench to enhance the book 10-12 times (next stepp will be using black blood and dragon powder), had to replace arcane staff by crafting a new one because i salvaged the first one by accident, should know 14 different spells (with rune symbol) now according to my book, instead of the expected 5 runes i only get three and behind these only 2 spells (“extend”?/Ausweiten behind all three runes), same effect after crafting the arcane staff learned thru battlepass,

Greetings Zaxarus!
Welcome to our forums and thank you for reporting your situation regarding Arcane Staff.

Personally, I’ve reached the last sorcery upgrade and I have all the spells available, so in order for us to be able to understand what is happening in your case, could you please let us know if you are playing on an Official Server or Private Server please? In case you are playing on a Private Server, are you perhaps using mods?

Also, could you send us a screenshot of your upgraded Tome of Kurak and of the first runes you see when you activate your staff please?

Thank you in advance!

Greeting High Saint,
i had a little problem with the ticket so a couple of infos got lost.
i’m playing on a modded private server [GER] Surviving Exiles.
Other players on my server don’t have the same problems.
The Tome of Karak has all upgrades now.
As a new user i can’t upload pictures apparently.
Just tried again, there are 4 runes: from left to right
1 use the power of life, death and undeath
2 conjure and control demons
3 make real thru deceiving all five senses
4 use the power of nature and reality
is there perhaps a problem because i had to recraft the arcane staff?

My apologies. I’ve updated your account in our forums, meaning you should be able to post pictures now :slightly_smiling_face:

It is possible that this is related to the mods in your server, plus a specific circumstance that you created - perhaps related to what happened to your arcane staff or related to something else - which enabled this to happen. Do you perhaps play on another server with no mods where you could easily try this?

You could also reach out to the Admin of your private server, due to the uniqueness of your situation.

I’ll speak with my admin.
Is there a way for him to reset my Sorcery? To set me back to the status before I entered the cave, learned it and got my first book/staff?

Certainly the admin of your server will be able to assist you with your doubt Zaxarus :slightly_smiling_face:

Let us know if you were to fix your issue!

Thx for the heads up :slight_smile: but the question was more meant as
“what has he to do / what flags to change to allow me starting anew with magic?”